App installation error

Hi, I downloaded my app from kodular creator and when I tried to install it, It is actually updating even though it’s not already installed! (no other app is using the same package name)

When I clicked on install, It says the app is not installed

I’ve tried everything, Please help me to solve this problem

Try renaming the app and save then compile…

What happens if you increase the version number in your app settings and then try again to build and install?

This can happen sometimes. You tried again?

Tried to uninstall the old version before installing the new?

Tried in another phone?

No old version is available. I am installing it for the first time

Not yet

I understood that it is the first time. I didn’t explaiyself very well.

may be it was installed the 1st you tried besides the message, so search for it in the apps list

Send the APK here so we can try to install it to see if it works

Thanks! It was my mistake. An app was already installed with the same package name, I couldn’t find it before because the app I was using to search other apps by their package name was not working properly.

1 Like

You’re wrong, the app exists. No doubt (so check that first!).

If the update then fails, there are usually 2 reasons:

  1. The version code is smaller (it needs to be higher for Play Store).
  2. The keystore is not the same.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.