App Not Installed Package Appears To Be Invalid Android 13

first of all hello to all of you like me many people must be facing this type of problem as you can see in the below image i can tag some people who are expert in these things if you know the solution If so let me know what is causing this issue only in Android 13 and 12, but running in Android 11, 10, 9 and all others.

@Peter @Boban @Diego :point_left::cat::motorcycle:

@Peter do you know anything about him​:unamused:

First, do not tag users just to get their attention if the problem is not urgent. This is not polite as we do not want to distract them.

This issue is due to multiple apps with the same package name. Please delete the old app that has the same package name as your app, then reinstall your app.

1 Like

this is small thing i make application i know about them but i am facing problem know about this application but android 12 and 13 showing message like this but this android Works smoothly in 11 if it is running then what is the problem in 12 and 13 due to which it is showing this type of message which you have seen in above image. @Gordon_Lu

Different devices have different operating systems. Just accept the fact that they are different, delete the old app with the same package name and reinstall!

1 Like

This post was flagged by the community and is temporarily hidden.

Again, do not tag users. This is very distracting.

What is your package name? Set it to a completely different package name and retry…also change the app name as well.

Finally found the problem it was not installing due to list view component so for future if any one have this problem you can suggest on list view. @Gordon_Lu :heart:


I have created an empty project with only list view component and it works perfectly! But Still cant find a solution this issue?

What is the exact error message?
Search for that in the community…


Yeah Same problem here

add android:exported = “true” in androidmenifest.xml file where
<activity android:name=“com.unity3d.player.UnityPlayerActivity” android:exported =“true” …
it will work fine as this exported should true for android 13 or upto 13

Same issues here in some devices it’s working fine but in most of the devices error appears

1 Like

im trying to downgrade an app because after my phone updated the app got ads( its a system app used to search everything) and its unusable now . tried downgrading , didnt work after deleting the app and clearing its data. higher version apps do work. is it a system version problem that it cant run the older ones

I had the same error only on Samsung smartphones. I had an extension which I tried and finally was useless so I disabled its procedures. This lead to the invalid package error. After I deleted the extension component the error disapeared and now works fine with Samsung ph.

any solution with the same package i don’t have 2 apps installed but its happening with me