"Application has stopped"


I’m developing an application and everything went well for its launch, working perfectly after several tests. It turns out that after the last Kodular update, the app displays the message “App has stopped” and automatically closes after one second.

Note: The app works normally in Kodular Companion, but it doesn’t work through the .APK file

Please does anyone know what I should do to proceed with my project? :sleepy:


Have you tried any of these?:

1 Like

Yes, I tested it with each component and the application still doesn’t open :sleepy:

Use logcat to find what causes crash

1 Like

Forgive me, I don’t know how to use LogCat to find my error.

If I upload my .AIA file here, can you find it?

If you wish post it here

Thank you for your help!

Attached is my application file.

I really don’t know what to do as your previous version worked normally on the Google Play Store. I didn’t change anything in its structure and programming and it suddenly started to fail…

Application link on Google Play Store: https://play.google.com/store/apps/details?id=br.com.legotunes.exercise

CargoScorer.aia (1.4 MB)

Here it is , problem was with switch components, if text on and text off is left empty causes app to crash


CargoScorer_1.aia (1.4 MB)


It works perfectly, thanks so much for the help!

1 Like

Teamwork Makes the Dream Work :slight_smile:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.