Attempt to get item number 0, of the list. The minimum valid item number is 1

I am geting error attempt to get item number 0 of the list…
and read many post but can’t get solution. Following is the block causing this error

Show us full block, how to you set or get values in global email… with this simple block no one can solve your problem

May be the email may not present in the global mail. Use if block to check first then try to save

its a login system with google spreadsheet. All data is fetch from sheet but the screenshot i post that function is not working

During screen intialise , did you get properly all the email and name form gsheet to the global variable?

yes, i get all data properly i will post the error screenshot.


I hope the problems is , I think you have tried it an app, before the list load it started to function. So use clock component in the exact place and in the clock timer block you use this select list item list. It will work fine . Still problem persists mean, you need to share your blocks

ok i will pm you the blocks

see the documentation of the index in list block

Returns the position of the_thing_in the list. If not in the list, returns 0.


can refer for more here

try this method…

(note: Do not use for each item of the list block, instead use for each number block. It will work fine in your case…)

you are right but my any of list is not empty

Yeap you list is not empty. But you didn’t understand the list.
As per your method you are adding items in global name as (name email pwd of first row)
In global email as (name email pwd of 2Nd row)
In global PWD as (name email pwd of 3rd row). If so it is not easy to find the correct index of the matching

But in my method I am adding global name as all the username and in email list as all the emails , in PWD list all the pwd . So it is very easy to find the index of the user id

In your case you blocks struggle to match the exact index.

I hope you understand it.

its my old method it worked fine before now

Still if you do not believe, use one label and catch the global name in your method also from my method . You will realise then why it says error in your method. Pls cross verify your method by using with labels or debug (Do it) at least

I checked using label all names are in global name and emails in global email

give me your screen as ais or aia. let me solve it

Thanx for you help and suggestion i have solve my problem

1 Like

I had clear the text box before getting the name that was the problem creator