Build failed by "unseen extension"

I checked out Kodular Fenix (v1.5.0) Bug Tracker before creating a new topic

i added extension about this →

and not showing in extension list.
and it makes build failing (even i dont need this extension anymore)
let me delete it? :disappointed_relieved:

ps / sometimes old or extension made for AI2 are occuring same symptom.
“extension added but cannot see. and its occurring failed to build, even not showing any information in build log”
and i tried export aia file and import again but still… nothing changed.

Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/…
________Creating listview xml in res/layout-v21/…
________Creating xml in res/drawable/…
________Creating splash png in res/drawable/…
________Creating colors xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________Creating provider_path xml
________Creating network_security_config xml
________Generating adaptive icon file
________Generating round adaptive icon file
________Generating adaptive icon background file
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
AAPT time: 1.138 seconds
________Compiling source files

i figured out why its happening. its not happening just do adding the extension (sorry for @Taifun i luv you). the extension will be can added well.
It was occurred from when im trying to add “.aia file” first in import window. ofc it showing me error and still import window is exist.

and then if i import real aix file in it, its showing me “completed” but not added in extension. maybe i think aia file had break the ‘extension area’ and replace aia data into when building.

but still cannot know “how to fix”.
bcz i added aix file once more(successed!) and delete it but still nothing changed.

Post your aia here if you wish so someone can check it

hahatest.aia (406.4 KB)
nothing showing in “extension” but smth exist in there as i think

and anyone can make it as i wrote

  1. choose random aia file into extension import as file accidently

  2. dont close the import window and choose real aix file

  3. see the successed.

  4. nothing in there

then you can make project been corrupted.

Project within a project. Try

hahatest.aia (1.3 KB)

then can i make it back to normal with extrator?

thank you!
im gonna press solution after do it

Download aia, open archive, go to assets, go to external_comps folder and if you see again assets, src and youngandroidproject folders delete them. Upload aia again to creator and compile

Thank you! done!
but also this is a bug that need to fix it → even if “failed” pop up is, but aia file extrected in aix feild…

whatever solved! thank you a lot

This is not a bug. You imported an aia in assets instead of impoting an aix using import extension in designer’s view

but there is some rule already shown

  1. the import window is only for aix files
  2. if i accidently insert aia file into it, showing “not a component file!” as failed to inser aia file, even if i wanted to do (whatever for reason)
  3. then it mean, whatever i wanted to do, the window is only for aix files. cannot be happen extrect aia file into it.

this is not about “user’s responsibility”. even if i insert a picture file into music player (and it showing ‘plz music?’), corrupting sequence is make no sense.

You most probably upload it to assets like this…

Nope, just i clicked wrong file by accident.
i didnt want to pick aia file ever into project. even nor in asset manager.
even i dont need aia file, but just the aia file extrected from zip together with aix.

did you ever tried this?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.