Camera component not working

Nevermind, just tested and it’s not working…

@Kodular package name causes this


My package name is App.Receitas and it is not working.

Definitely the problem is package name.
I have run an example without package name and it worked.
I ran the same app with package name and it did not work.

I need to use package name because I am using Firebase Storage and Firebase Realtime database.

Yes, my problem too got solved after i removed the package name, and let the kodular decide it. It worked!!

Try to change this in the Manifest:

io.kodular to e.g. com (in my example)
in this line
<provider android:authorities=""


Works on a Galaxy A3, Android 8.

I do not know where we could find this manifest file.

Try using APK Easy tool, decompile apk, edit manifest file and compile it again

1 Like

Works for me creating a new project and testing on android 9.

What happens if you change the package name

I made this test and crach the app with the same error.

I created other app with a package name and the app broken. Maybe the problem was the package name be setting wrong in some native config file on build process.

Well, I do not know what happens to my package name, I leave the package name empty and then I will install the app on my huawei p30 and “application not installed” I write package name and the same as “com.darpid.cliente”, "com .darpid.clientes “, but curiously with this package name” com.darpid.client "if you let me install, this also happens with samsung j2 prime.

Uninstall your previous app

1 Like

@Kodular is there any progress in this

i tried it & working fine.

i implement same block in my code. i am also attaching block image.

my problem is after Picture captured image take time to appear in image1. some times it takes 5 to 10 seconds.

except this problem i have no issue.

any idea to sort out this.

Don’t know as it shows instantly on my device, may have to do with the quality of the image, how big image is in px, your device etc.

Yes, I have the same issue on a Galaxy A3, Android 8 (but not always and only at the first time).

I changed the packageName from to
on the old (“hard”) way and everything works fine.

Here is the Manifest:

@Kodular Something to take care of.

See also here:

1 Like