Cannot find the component

After kodular fenix update. some of extension of my project not working. Saying not found. I tired to update with recast. but they haven’t any library. extension are pager & reflex. that extension work in my other screen. in two screen of my project that extension doesn’t working
Screenshot 2021-07-25 215407

1 Like

Is this aia come from mit app inventor?

nope. kodular. that was worked before update.

Is your companion upto dated? Is it displays 1.5.0 fenix

yes, i updated all

You need to use updated reflex. But pager have no problem so far i think

as i said i tried

I have checked , no problem i found. Better clear your browser cache , logout then try again. I am not sure. BTW go to setting, and check whether default theme is set or not . If it is set as blank please choose anyone. I find these problems only the apps come from. Mit app inventor but that too after the evolution of Fenix

man that extension work in my other screen. in two screen of my project that extension doesn’t working

I have no idea then. Let me see how others are responding to this.

1 Like

The pager extension was made with Android Support View Pager. Then it may cause the error if you’re not using androidx version. Have you tried to recast the Pager extension to androidx?.

BTW, you can try to use the extension in a blank screen then check which extensions are throwing the errors. If you found then you can migrate them.

I updated to x version with recast. but extension blocks are throwing error

@Sumit1334 your custom indicator extension also throwing error
Screenshot 2021-07-26 121439

Then it may possible that other extension need migration.
You can try to migrate your whole aia file with recast. Then see if throws error. Or you can try this once so you can know the extension that needs migration.

Make sure you have the latest version of extension in your project. When the extension was launched then 2 versions are posted. I think you were downloaded the support version of the extension and then didn’t updated it to make it suitable for fenix. Now support version has been removed from there and only androidx version download link is available there.