Cannot update extension


(Philipp Lang) #1

Hey guys, i have a problem i cannot update a component. If i take a other project and i load the new extension into the app, i see the new blocks what the extension should have with the update.
But if i have the extension in the app and i load the update into it i get each time the msg: Component successfully updated. After that i get the msg a error happend. If i refresh the app i dont see the new blocks what i should have. But as i told if i take a app where the extension is not inside it works.

But what i dont understand, i get for each extension a error after i import it in the app.
Each time i get the msg: A error happend.

I dont wont to delete the extension bc i loose all my blocks what this extension give me and thats is not less.


(Cian) #2

You may have a conflict with an existing extension.

What extensions are you using right now?


(Nathan) #3

This happens to me too :sweat_smile: You have to update the extension separately for each screen sometimes… Save the project, then an AIA. Make sure to save it like 10 times :joy: otherwise it won’t work.


(Django's Android Apps) #4

For me normally this works:
Add the related blocks to the backpack.save your project. Maybe via Checkpoint too. Export aia. Save it too. Open a copy of the aia in winrar. Scroll to the directory where you find the extension to delete. Delete it. Save the changes. Reimport the aia to kodular. Of course you first have to delete your original project to import the fixed one.Add the new extension.paste the blocks from your backpack and do some fixes as they may show red.
Hope this helps.


(avmcreators02) #5

Try this one

  1. Download project aia file
  2. Open project file and extension with zip view (Winzar, 7Zip)
  3. Open asset’s folder and then open external components folder
  4. Drag and drop updated extension files to your project files

(Philipp Lang) #6

i use dynamic card view extension which a user posted the last days.
i deleted it in all screens and than i deleted the extension.
Thats worked for me.
I cannot upload my project if i download a aia and i want to upload it again. It takes me a complete day to import my project again from a aia. I cannt save my project under a new name. I get each time a error. That it is not possible to upload that project at the moment.
I dont know why but it is so.
The only way whcich work is to make a new project and in the project i can import a project from a aia.
And thats does not work each time. I tried it 100 times and from 100 times i get my project possible in the builder.
That Problem is here for me since i worked on the other server.
I dont want to try to delete my project and try to upload it again bc i am scary.If i cannot upload my project again, more as 1000 hours of work are gone if it dont work the next time.
So i let the things how it works.
Never change a running system.

But thanks for that solution. It is a good way to solve such other issues too.