Card view size bug

Describe your issue:

I’ve put a cardview on a screen and i’ve set the width and the height to “Fill parent” :

But, in the live test in Makeroid compagnon, the size don’t change :

Even if I put 100%, it does not change anything, the size of the cards is not taken into consideration

Steps to reproduce the issue:

Try to change the size of a card, then see on the live test

Expected Behaviour:

The card size change on the live test

Actual Behaviour:

The card size doesn’t change

Sorry for my bad english, i’m french

Work arround:
Let the card size option by default.
Add a component into the card layout.
Then give only your added component a size.
The card will be then so big like it’s (childs) components into it.

I’ve tried a linear progress set to “Fill parent” into the card, but it still small :

(I have not changed any properties of the card)

What about any other component?

The card take the size of the components, but the width and the height options still only working on the builder preview :frowning:

I will look into it and let you know if I find a solution :slight_smile:
For now let the card size default and give only components inside it the wanted size

1 Like

Thanks ! I will use basic layout for now !

1 Like

Mets un arrangelent “fill parent” dedans, ça devrait marcher ! :wink:

Thanks for letting us know the bug.
I have fixed it for next release :slight_smile:

For now you can set the Cardview width to 100% and put an arrangement in it, with the width to 90% and then buttons if you put any in them, set the width to 60% for fill or let them go.


For me, the update hasn’t changed anything about cardviews, and it’s worse than before!
So I used from a layout, where I checked “Is card”, that I could use without worries, but now, their widths remain at 100%, that I put 80% or 10%, it remains as I put “Fill parent”

It still fits well to the size asked if I uncheck “Is card”

Why are you talking about “is Card”? This is no card layout property.

We have fixed the cardview bug^^

And that you see that we have fixed the card view bug do the same like in your first post.
Add a cardview and that resolution as example 50% and 50%.

1 Like

Yes, there is this option:)

I’ll check the size of the cards.

And for layout card problems, just put it in another one that has the right size

Do what I wrote above and then show us a screenshot.
I know that layouts have the “is Card” option because I have created that…

You was talking in the first post of your topic about the CARD VIEW and not LAYOUTS

1 Like

I have no idea why its not working for you.
Iam away from computer.
I test it tomorrow.

Btw how does it look if you add a component insider the card?

Ok no worries, I use layout anyway :slight_smile:
Thank you !

What happens if you set a component insider the card?

The Play Store did not update automatically! I went to do it and it works now :slight_smile:
Sorry :flushed:

Oh. And I thought you showed me a apk :smile:
So all is working how it should?