ChatAble - A chat system

I guess it’s because of the Dialogs extension, whichw as integrated as component into Makeroid

But the same error happens on Thunkable

But Makeroid has more dialog blocks…

Tried but doesn’t it just stops when the errors occur

The operation > cannot accept the arguments: , [“Incorrect Key”], [278]
Note: You will not see another error reported for 5 seconds.

my proyect

Runtime Error

The operation > cannot accept the arguments: , [“Incorrect Key”], [278]
Note: You will not see another error reported for 5 seconds.

I want to make a app… when some one download and register few steps and they can ask quotations from me… and I can replay for there massages how can I do this thing

no longer compiles . gives error .

Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/…
________Creating listview xml in res/layout-v21/…
________Creating xml in res/drawable/…
________Creating splash png in res/drawable/…
________Creating colors xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________Creating provider_path xml
________Creating network_security_config xml
________Generating adaptive icon file
________Generating round adaptive icon file
________Generating adaptive icon background file
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
AAPT time: 0.804 seconds
________Compiling source files
(compiling io/kodular/sales/ChatAble_Public/supportChat.yail to io.kodular.sales.ChatAble_Public.supportChat)
(compiling io/kodular/sales/ChatAble_Public/adminServer.yail to io.kodular.sales.ChatAble_Public.adminServer)
(compiling io/kodular/sales/ChatAble_Public/admin.yail to io.kodular.sales.ChatAble_Public.admin)
(compiling io/kodular/sales/ChatAble_Public/support.yail to
(compiling io/kodular/sales/ChatAble_Public/privateChat.yail to io.kodular.sales.ChatAble_Public.privateChat)
(compiling io/kodular/sales/ChatAble_Public/access.yail to io.kodular.sales.ChatAble_Public.access)
(compiling io/kodular/sales/ChatAble_Public/private.yail to io.kodular.sales.ChatAble_Public.private)
(compiling io/kodular/sales/ChatAble_Public/editAccount.yail to io.kodular.sales.ChatAble_Public.editAccount)
(compiling io/kodular/sales/ChatAble_Public/about.yail to io.kodular.sales.ChatAble_Public.about)
(compiling io/kodular/sales/ChatAble_Public/group.yail to
(compiling io/kodular/sales/ChatAble_Public/Screen1.yail to io.kodular.sales.ChatAble_Public.Screen1)
(compiling io/kodular/sales/ChatAble_Public/myAccount.yail to io.kodular.sales.ChatAble_Public.myAccount)
(compiling io/kodular/sales/ChatAble_Public/groupChat.yail to io.kodular.sales.ChatAble_Public.groupChat)
(compiling io/kodular/sales/ChatAble_Public/adminSupportChat.yail to io.kodular.sales.ChatAble_Public.adminSupportChat)
(compiling io/kodular/sales/ChatAble_Public/adminSupport.yail to io.kodular.sales.ChatAble_Public.adminSupport)
(compiling io/kodular/sales/ChatAble_Public/home.yail to io.kodular.sales.ChatAble_Public.home)
(compiling io/kodular/sales/ChatAble_Public/adminUsers.yail to io.kodular.sales.ChatAble_Public.adminUsers)
(compiling /tmp/runtime7025395418856314227.scm to
Kawa compile time: 4.567 seconds
________Invoking DX
DX time: 6.939 seconds
________Invoking ApkBuilder Failed to add /tmp/1598983952683_0.10136479338178339-0/youngandroidproject/…/build/tmp/classes3.dex
YAIL compiler - ApkBuilder failed.

anyone have any idea what needs changed .

ChatAble_Public2.aia (804.1 KB)

Where’s the APK lol

No Diego promised it 2+ years ago :rofl:

if it would compile . we would have our own


It has probably to do to old extensions which now exist as component and thereby conflict with the server when build…

1 Like

i see

tried converting … but very hard without a search in blocks area .

thinking about this is actually very scary . it means kodular is not backwards compatible with apps we develop .

It depends, as stuff gets updated such as. builders, requirements for extensions etc, for the records those extensions was build before Kodular(Makeroid) was born…

1 Like

Hello @Diego can you PM me or allow me to PM you please :pray:t2:

How can we change the main source of the servers? I cannot compile an APK with the AIA you provided

Kodular compiler could not compile it. what to do ?
even niotron too… :pensive: