Chromecast extension?

Is there any extension for using chromecast in your apps? I am wanting to make a game involving a chromecast and am unable to find an extension for this. Anybody know of/willing to make a chromecast extension?

Here is something I found if it helps: https://github.com/vitalidze/chromecast-java-api-v2

1 Like

I changed category

In fact I would also like to have a Chromecast / DNLA extension

If your situation were multimedia content (Audio / video) I have a medium effective solution, but you are developing a game, so I can not help you

You can ask to any @ExtensionDevelopers

It only requires one device, and the content displayed onscreen is somewhat multimedia, where can I find your extension?

can you share us how to chrome cast audio or video

Well, my way to do it is using ActivityStarter and the Web Video Caster application

Supports the ActivityStarter extras found on this site:

API - Intent definition - MX Player (yes, the MX Player site)

For now I have only used the Title, SecureURI, Image / Poster extras

1 Like

how do you secure link, can you share blocks

With this extra, is a boolean

it will be helpful if you share block image , and another thing how to use split screen when video player , i tried but video gets paused when i use other app

I’ll see what I can do to make this :slightly_smiling_face:

1 Like

Yei!!! :smiley::smiley: Great notice!

What’s funny, is they all laugh until it’s done :joy:, I’m starting to work on it now!

:flushed: It’s building…
:joy: One thing I noticed I messed up was where I was building, I was building the components folder and I kept wondering why it was unable to create a temporary build directory, I’m so stupid LOL, building again, in the right directory
:white_check_mark: Not surprisingly, it built! Now to testing.

3 Likes

I want to test :slightly_smiling_face:, i can? :grin:

1 Like

No one said it works :joy: I just said it built.

#EpicTroll :joy:

It wasn’t a troll though, the extension built successfully, but I didn’t say anything in it worked, I’m getting this one error I can’t get rid of :joy:

I’m 100% sure it’s because I’m using VS Code and that’s what’s causing it.

1 Like

I don’t have idea :slight_smile:

1 Like

Hey @MeteorCoder!

I need to contact you about this extension, but you have the PM disabled :confused:

As of now this issue is still unsolved and I’m taking another look now before asking for help. As I said, I 100% think it’s because VS Code imported something it wasn’t supposed to since it’s bringing up the import it brought in as an error although I removed the import.

UPDATE

Thanks to Even P. from the App Inventor Community, I was able to mitigate the errors to just a few which I should have fixed within the next few hours to days. I’ll most likely be working on this at school, so it might be done tomorrow.