Compile error on YAIL compile APK BUILDER

I got this error while compiling app

Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/…
________Creating listview xml in res/layout-v21/…
________Creating xml in res/drawable/…
________Creating splash png in res/drawable/…
________Creating colors xml
________Creating strings xml
________Creating styles xml
________Creating styles xml v21
________Creating drawables xml v21
________Checking for firebase
________________Firebase components found.
________________Firebase config file successfully added.
________Creating provider_path xml
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
AAPT time: 0.596 seconds
________Compiling source files
(compiling io/kodular/sushil_balami200/eicaid/Screen1.yail to io.kodular.sushil_balami200.eicaid.Screen1)
(compiling io/kodular/sushil_balami200/eicaid/main.yail to io.kodular.sushil_balami200.eicaid.main)
(compiling io/kodular/sushil_balami200/eicaid/home.yail to io.kodular.sushil_balami200.eicaid.home)
(compiling io/kodular/sushil_balami200/eicaid/social.yail to io.kodular.sushil_balami200.eicaid.social)
(compiling /tmp/runtime8645943936746769338.scm to com.google.youngandroid.runtime)
Kawa compile time: 1.76 seconds
________Invoking DX
DX time: 5.56 seconds
________Invoking ApkBuilder
com.android.sdklib.build.ApkCreationException: Failed to add /tmp/1551100085893_0.8028876779255923-0/youngandroidproject/…/build/tmp/classes3.dex
YAIL compiler - ApkBuilder failed.

is there any way to fix it

@KodularCreator
??

Here is a great list of things to check on why a AI project may not build. Go through it and see if anything helps.

1 Like

How big is your aia file

/Boban

1 Like

2 mb is the size

I have taken a quick look at these threads with similar error Search results for 'Failed to add /tmp' - Kodular Community

It can be related to

  • package name
  • files with diferent capitals
  • extensions
  • email if it has number in the beginning

And you could have done this yourself

/Boban

3 Likes

Done not fixed. !

My AIA file size is… 2 mb
.there are not any extension… problem…
All blocks are correct…
I knew that… kodular has not ability to compile large apps

Save AIA to desktop. Reimport it as a new app. Try to compile again.

The system does a bunch of checks and reorganization when importing an AIA.

Done already nothing happens same error
May
@Diego
Fix it

Did you try a new browser?

I have used Chrome

try Firefox

Many usually say so but their code is way off.

Up to 20 MB if I remember correctly.

Either you share your aia file so someone can take a look at it

/Boban

1 Like

Used same error

Private AIA… Sorry bro…

PM it to myself or Boban, or someone else who offers. Otherwise you are going to have to figure it out yourself.

2 Likes

I can only wish you good luck then.

/Boban

3 Likes

To whom may I trust !
@Boban

It’s private and necessary app so

when you use 2 extension having same library you will face this error can you name which extensions you use

1 Like

i will give u my bvrowser aia can you fix it and give me aia please