Date not read correctly

I save data in my dictionary with year,month and day like key (from clock block ) but when I try to get data using “get value at key path” give me error. If I write the keys like text all work fine . There is a right way to get value from clock?

first one get error, the second one is a test and works fine

the block I use to save

My dictionary tree

Do It Result: {“CODICI”:{“111”:{“NOME”:“RISO”,“QUANTITA’”:“3”,“PREZZI”:{“2023”:{“febbraio”:{“3”:4}}}},“222”:{“NOME”:“PANE”,“PREZZI”:{“2023”:{“febbraio”:{“3”:4}}},“QUANTITA’”:“3”}}}

Nothing about my problem?
Sometimes I have problem also with walk at all level block :unamused: but this block works only if I saved data under a list? like this? :point_down:

can you share us your dict in proper format?

above code is not proper json format, i mean the symbol

1 Like

Probably this is the problem but I don’t understand where is my error. There is some error in my way to store data in dictionary. In the firt post I give you all my do it result . Start with empty dictionary and use the second pic of my first post, then I posted the do it result :man_shrugging:

And … if the problem is a syntax error why it works with text and doesn’t work with date block ?

i repeat just share your global dictionary in proper style in order to help you better or to spot the error exactly…

or click do it in this make a list block and share us the screenshot


so i believe now you know why it didnt work with block

see here the last value is 7 (so it returned Not found) but in string you have used 3 and you got the value…

Yes because today is 7 , when I got the error was 3 of February.

See in your dic the item present is 3… so you wont get result as not found but if you are looking for the key value of 7 then it will give result as not found…

Your data reads correctly… no issue

same blocks but different results… Very strange… why??

See only the pics of the first post , today I didn’t tried so I haven’t the screenshot with 7 in the dictionary.
I tried in 3 of February, today I make a screenshot only for you to test the list block, I am at work now.
If you want both pics of today I can try tonight, perhaps :disappointed:

Dear, there is no need of our help in your case as it is working properlly … since you have tested on 3rd feb it works, but now the date is 7 so it throws error… thats all… In your dictionary you have saved the 3rd feb as a key value… so what we can help ourself to you dear?

When I tried was 3 of February and didn’t work . The post is of 4 days ago and also the first pic. Delete the pic with 7 that I made now only to test the right syntax of the list block because you said me that there is 3 errors in Json

if possible share us your demo aia

The last two days all work right :man_shrugging:t2: I don’t know why that day it didn’t work. A server error ? Cache problem ? Bad internet connection? :man_shrugging:t2: Usually I don’t waste time for stupid or known issues .
Thanks for help

I updated my post . Thank you.