Default selection of Number Picker (Notifier)

bug

#1

Describe your issue

When the Number picker is initialized and if we press ‘Ok’ without making any selection, then the default selection is ‘0’
May be a possible bug?

Steps to reproduce the issue

Just press ‘ok’ without scrolling through any other options

Expected Behaviour

The actual number (current number) should get selected

Actual Behaviour

Instead it displays ‘0’ as the selection.

Show your Blocks

Android version

Android 6.0 Marshmallow


#2

Thanks for catching this bug.


#3

@Mika
Glad to hear from you. Can I expect it’s solution in next possible release?


#4

Yes should be fixed


(David Ningthoujam) #5

@Mika you are superHero :stuck_out_tongue:


#6

@Mika
If you mean to say that it is already fixed, then no it’s not fixed yet. OR Did you meant to say that it would be fixed in next update?

@David
Did you marked it as a solution? If yes, then please don’t, before being confirmed of the actual answer


(David Ningthoujam) #7

@Vaibhav

Its written clearly he said should be fixed, not it has been fixed.

Na, i didn’t.


#8

I found the reply a little confusing, and so was the question!

Ok


#9

It is fixed for next release


#10

Thanks for the clarification!


#11

Hello @Mika

Was this bug solved in the latest update i.e :point_right: Kodular Draco 🐉 (As i read something like Notifier returning Null pointer exception)

If yes then please check again, as it seems that it is not solved. Let me know if I am missing something.


#12

The wrong selection bug should be solved in latest release.
Please create a new and prepare a simple example file with the bug


#13

Sorry @Mika for the late reply.

I just noticed that the bug occurs in the companion while live testing, but in finished apk there is no bug. Let me know if you still want example project. Thank you


#14

Have you updated the companion?
It should work there too :joy:


#15

Yes the companion is running on the version: 1.3B Draco.

Edit: I cleared up the cache and it somehow started working. Now no bugs in companion or in final apk!