[Deprecated] Avoid Crashes of the Application for some of the components

I completed all the empty fields.
Unfortunately, the application does not start.

Does anyone on the kodular team know when this will be fixed?

1 Like

Did you checked logs ?

If not check logs to know why crashing

Logcat. I ran it several times.
You can see there are bugs, but I don’t know where to find them in the kodular anyway.

adb.txt (16.9 KB)

But in companion everything works fine

I am sure that you have some fields empty since I see error unbound location null

10-01 22:23:23.530  8768  8768 E AndroidRuntime: java.lang.RuntimeException: Unable to start activity ComponentInfo{com.radio.pl/io.kodular.sp4ubw.Radio_Polska.Screen1}: /tmp/1633113323535_0.7147894262474823-0/youngandroidproject/../src/io/kodular/sp4ubw/Radio_Polska/Screen1.yail:9273:57: unbound location null

I went through all the components one by one and the application works.

Thanks for the hint.

I also had to update one of the extensions. Exactly:

Everything works fine now.

This was just wishful thinking

Since the new update 1.5.3 there is no issue any more, at least at my side.

Kodular Fenix 🔥🐦 - #5

Can others test this theory as well.


did you check android version 11 with unity ads?
I using unity and check android 11, it continues crashing.

1 Like

I think I spoke too early about this

:man_facepalming: :man_facepalming: :man_facepalming:


How long will it take you to solve this problem?

Or will it go this way?

Won’t you solve it?

A post was split to a new topic: Doubts about Gallery on Android 11

my unity is making it crash too

I’m having a problem with the Floating Action Button, I tried to put the “Material Icon” for Whatsapp and it didn’t recognize it, it’s ok but when I try to import a photo to FAB it doesn’t recognize it because it can’t let the “Material Icon” empty, then it doesn’t let the photo be shown!

Please try to update the “Material Icon” in general, there are icons that are not supported! :pray:

The last update from Kodular reminds me of iOS 13, because this was the most buggy update ever from Apple. There have been 17 updates to iOS 13 (in a few weeks).

But Kodular should at least try to fix the current (serious) bugs (at least on the test / beta server). However, we haven’t received any feedback from the Kodular team for weeks. :upside_down_face:


I agree, kodular customer service has to improve, at least as ankie says one answer or communique for the community, but the silence does not tell us anything, they only speak fast when monetization is talked about: /


That’s right. There are many software bugs.
I do not even write about many anymore because there is no reaction from the kodular team.


this is not working i will send you my app aia please chk it and slove my Problem please.
FreeFire_Leauge.aia (3.7 MB)

I have used Admob and Spreadsheet component in my project.
For Admob Banner and Interstitial Ad Consent Title and Consent Message fields are not empty and for Spreadsheet View Name is also not empty still the screen not opening and the app is keep crashing.

If you checked About Screen Title, all those component properties & extension fields then you may post logs to know the reason of crash

1 Like

I just try to preview the crash report and attached the screenshot of the crash report.