Does anyone know why webview cannot open the url in several project app?

webview doesn’t work in my new app builded but another project it works.

does anyone know the solution?

Do you know about this? :thinking:


i’ve searched but not get good answer that i want so i ask again

@OfficialDjJohn showed you the link because you don’t give any information at all. If you want help show some information.

1 Like

I have the solution: it works!!

You don’t explain anything, you don’t say what the error messages are, you don’t show any blocks, and you expect someone to help you?


blank webview.
this is the block

this block work in my another project but not in my new project
i have tried using go to url block and home url block


I have done it as well, but :pensive: it still doesn’t work

What does not work? Did you connect to Companion before?

yes, i clicked the block “select list item list” and clicked right that clicked “do it”

and got the same result “blank webview”

i think this project is corrupt.

post images of where did you initialize or insert data in Global link_modul

Let us see what you get with “Do it Result”,
something like this:
copy it and post it.
If it is empty, then post the appropriate blocks to these:

i change my block, the “do it” cannot be clicked
the url i wanna open is pdf from google drive.

always got same result : “blank webview (white screen)”

Do it only works together with the companion app…
Live Development, Testing, and Debugging Tools
see also tip 4 here App Inventor: How to Learn | Pura Vida Apps


1 Like

As I wrote:

1 Like