Does companion have storage access?(FTP Issue)

Hi people. I can’t work with files on companion preview. Does companion have storage access? if not, is there a way for testing file transfers like ftp without baking and installing apks? Thanks.

Companion has the same “storage” as a regular apk. What is your exact issue. Please show the blocks or screenshots

I try to upload an image from image picker to an ftp server but it says “no such file or directory”. I put screenshots here(first one is the blocks and the other one is after hitting the upload button) maybe you can tell me what I am doing wrong.

Well first off it is three slashes not one.

But you should not need it. Image Picker is not picking from assets.

And what happens when you drop the file:/ and just put the selection?

1 Like

No matter how many slashes I put there, It just won’t work. Label1 returns true which means connection is ok but for unknown reason it won’t upload file or make or remove dir. When I put selection alone, label3 returns blank and nothing changes on ftp server. I’m confused :confounded:

Does the button change to green?

1 Like

No it doesn’t turn green. I tried the code everywhere but still no hope. Maybe its a compatibility issue like server only accepting predefined ftp agents.

Ok, so the file is not being uploaded. FTP requires two ports to send data.

Port 21 is for the connection, and port 20 is the data port.

Try this AIA I put in another post. It uses a server that will hold the image for 30 minutes and then delete it, so you can try it.


1 Like

I tried your project but it returned “false” and did nothing. then I replaced ftp address with my own and it gave me a “true” this time but again no upload. this shouldn’t be a port issue because I’m able to access ftp using windows explorer on the same network. I think ftp component doesn’t work properly with some providers. I will try another server and post the result here. thanks for the help my friend.

Tele2 provides , you can log in as anonymous and upload anything to test your upload speed. For download testing they provide fixed size files, you can choose which fits best to your test.

You can connect with username of anonymous and any password (e.g. anonymous ). You can upload files to upload folder. You can’t create new folder here. Your file is deleted immediately after successful upload.

1 Like

UPDATE: Hi again. I finally managed to solve the issue by changing my ftp server. I don’t know what was the issue with that provider but it didn’t let me transfer files from the app. I tried a free ftp from and it worked perfectly. also I found on google that some ftp clients miss passive mode which is needed because without passive mode the user will need to open ports on dsl router to connect to ftp. I hereby ask developers to enable passive mode on ftp component. Thanks.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.