Doesn't getting path to image component

Hey guys,

I am using Image utilities to load a link from a list to the imgTMP component as you can see in these blocks:
So far, so good… this block is working perfectly, but in the next block I add a item to List View Image and Text, the image should be the imgTMP Picture but nothing happens.
I tried to see through a TryCatch message the imgTMP path but it’s a empty string.
I tought it was due to the time that takes to load the image and I’ve made some tests with clocks but it didn’t worked.
I’ve tried to pass the value to a variable but it didn’t worked too.
Now I am trying to use activity starter to get the data uri from the component but I don’t know how it works.
I’m running out of options here, I really would appreciate some help!

Have you read the blocks description which components are supported current?


Don’t get it, what you mean?

You should read the blocks description

So you are saying that the answer to my question is in the blocks description?
I’ve read it man, way before I open this topic, if you where right we woudn’t even having this conversation.
If it’s too much trouble to you to help, then please don’t…

Supported components:
Image, Buttons, Layouts, Canvas.

Means the Listview with Image and text component is current not supported…

Yeah, and I tought I was doing it right here:

At the moment that this block is read, the imgTMP.Picture has an image loaded from the internet.
The expected behavior was that imgTMP.Picture has the path to a temporary file, a cached image, something like that, but instead of that, there’s nothing.
As you can see I set a message block in the end to display it’s content but I got a empty message.
All I want to do is to load a image from the internet to the image conector in the add item from List View Image and Text block, so I loaded it into a image component and set his .Picture block to be the image from the add item block.
If there is another way to do that I would like to know, any help are welcome.

Could someone please give me a hand in it?

Use direct URL instead of image picture.
But this will only work only if you have internet connection.

Simply as that, solved the issue Sunny, thank you very much! :clap::clap::clap:
I didn’t know that I could paste a link in that connector. :sweat_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.