Download an APK to App-Specific Directory (ASD) and install it without permissions

No, this version 6 is for testing purposes only (for now).

Ok that is clear thanks

But if you have the same problem as @Choofa, then test the new version and if it works, I will upgrade this (new) version officially after I get (positive) feedback from him as well.

Sorry for the delay, haven’t had time yet, to much at home with the kids. I will try to test it tonight :blush:

I have now tested v.6 of your extension provided.

It works without any complications when compiling. It downloaded and started the installation like it should :+1: :clap:

Thank you :blush:

1 Like

I added also two new blocks now, so you can check if the APK is already downloaded (exists) and you can delete it again.

I’ll release this version then tomorrow.


Just done.

1 Like

Try now, might be it will work now with both extensions​:+1:

This also includes @Alex :blush:

This post was flagged by the community and is temporarily hidden.

i am installing apk in app .
i have test it on adroid 6 its working great,
but same method dose not working in android 11 ,
please help

are you using the latest version 6 of the extension?

Yes i am using latest version ,
Also i am downloading same application apk file and trying to install it .
Is this method cause error ?

Hi. Could it be that on Android 6 the path E-billing will be created automatic if not exists, but on Android 11 not?

I use Android 11 on both phones and have no problem with install after download.

Tried to download directly to ASD and see if that works?

Apk download successfully in ASD , in both android versions 6 and 11.
But when i use install that apk , it installed successfully on Android 6 but not even open in android 11

Are you downloading same application in asd and then installing it ?
Or you are downloading another application?

Actually tried both. And both works fine for me.

Edit: Have you tried to download the APK manually to phone with Android 11 to see if it actually starts install when you open file?

Yes after download in asd , i tried to install with extension in android 11 but nothing happens, then i manually install it and get successfully installed

@bodymindpower any solution for me ??

Kodular does not declare
<uses-permission android:name="android.permission.REQUEST_INSTALL_PACKAGES"/>
in the Manifest (like AI2 does). So added it now to the extension:

Try this one: de.bodymindpower.installApk.aix (11.2 KB)