Dynamic components unique ID error

You said it without even trying. why don’t you try first and then say.
I will share my blocks.

This is your issue and I am here helping you and you are saying to me that I must try first everything before I post here anything. I need to make this large blocks before trying.Do you know how much time it consumes. If you will say this then nobody will help you…
Sorry if I say anything wrong to you…

3 Likes

I will take over now @Sumit1334 :)

@sanatmalani You’re doing something wrong… I developed the method to remove components properly and it worked when I implemented it.

2 Likes

okay I will post my blocks

So that you are, once again aware, that your blocks are wrong… The following blocks work perfectly fine.

2 Likes

These are my blocks

the link you shared has a zip folder, but couldn’t find aix file in it. From where shall I download aix file?


I shared a link that should’ve opened GitHub, I didn’t give you the download link to anything.

Also, it’s confusing to understand your blocks. You are using multiple components to create one component, you’re using more blocks than you need to, it’s all over the place.

Why you are putting Remove block in else condition. It must be called before the for each number loop to delete the old component first.

that’s right I downloaded the zip folder but couldn’t find aix file in it.

I didn’t give you a link to download anything :smiley:

1 Like

I used these blocks, it is not working properly. I tried.

@hammerhai What is the purpose of the link you shared? I thought you updated the aix file.

I am trying to fix this since past two weeks, your help and support is very much appreciated.

And what do you mean by properly here???
May you please tell me is the same error coming now or any other thing??

there are no labels when I click again.

Mean the problem is now in your procedure.
Have you changed anything in your procedure blocks.
And please also post new blocks(if you changed your procedure) and design screenshot

I haven’t changed anything in my procedure blocks.

If you’re having trouble creating labels with the extension, I had the same issue.

Kodular in built dynamic component can be created with duplicate ids.
You should also delete that label that you have created with kodular in built dynamic label component.
With this block

Then try.

@sanatmalani is not using extension for creating labels as I can see in blocks… :upside_down_face:

2 Likes

Getting error in using delete label component

The thing is I am getting unique ID error even when using clock method to load components, which shouldn’t happen.

I don’t know what is wrong.

And what’s the error ?
May you please pm me your aia file so I can check what wrong you are doing. But before giving the aia please tell me error that you are facing in deleting the label component.

these are the blocks of clock

the error while using delete label component. The operation DeleteLabel cannot accept the arguments: , [vrr172]