Error 701, unable to load file:///storage/emulated/0/Download/… But the video is playing …

In Taifun’s blocks, in the 'When Screen1 Permission Granted ’ block Can you explain what this ‘Package1. Packagename’ is ? where to find that block ?

See here (pont 4): How to ask a question (open new topic) - Tutorials and Guides - MIT App Inventor Community


Thanks a lot, i am now able to run the video in my app.

Only issue still i am facing is that when i open the screen of the video, i keep getting the error message ’ Error 701, unable to load file:///storage/emulated/0/Download/… But the video is playing …

How can i suppress this error message ?

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select “Download Blocks as Image”. You might want to use an image editor to crop etc. if required. Then post it here in the community.


1 Like

Thanks a lot for the response. Below is my blocks image.
Note, that i have a small video file (1.9 MB) that is loaded into the assets of Kodular and used.
But once it is packaged, i used the APK Editor studio to replace the small file with a 49 MB video file.

1 Like

Tried this, but i still get the same error… Please not that when i use it with the video loaded via the assets, then i am not facing the error message.

When i replace the video with a bigger file using APK Editor Studio, then i am facing this issue.

When do you get this error? At Screen.Initialize or …?

I get the error when the screen is initiated… I have created a button and applied a picture for it… when user click it, the video player will play the video on full screen…

As mentioned, i get the error message, whenever i come to this screen, but when i click the button, the video plays…

I cannot reproduce this issue, but try this (empty block):


No Luck still… sharing the screen shot of the error message…

This error message come up every time when the screen is initialized… the video is linked to the black space on top (button). when the button is clicked the video is playing…

When the app is installed and when i open this screen, the first time, the error pops up and then goes and it asks for the permission to access the photos, media and files on the device.

When i click allow and then click the button, the video plays. But when i click back and go to the home screen and then come back to this screen i get this message…

Post the aia.

For_Community_testing.aia (2.6 MB)

Attaching the aia which the home screen and the video screen…the button at the bottom of the home screen ‘Introduction…’ is used to move to the video screen.

No issue / error, neither with a 1.7MB nor with a 60MB video.
(Note8, Android 9)

Oh, that good… then may be i am going wrong somewhere during the process of replacing the video with the APK Editor studio… I have followed your video on that and attempted it… is there any way to check where it is going wrong ?

Also, pls note, post installing the apk, when you open the first time and go to this screen, i am not getting the error, but when i go back to the main screen and then come to this screen again, then the error comes…