Error build apk: DX execution failed

when i try to build the apk i get this error:

Makeroid is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
AAPT time: 0.355 seconds
________Compiling source files
(compiling com/makeroid/ivanMORENOripoll/RascayGana/Screen1.yail to com.makeroid.ivanMORENOripoll.RascayGana.Screen1)
(compiling /tmp/runtime1141469235431208868.scm to
Kawa compile time: 3.649 seconds
________Invoking DX
YAIL compiler - DX execution failed.

1 Like

Concerning DX execution failed generally there is SteveJG’s monster list


1 Like

I have already managed to solve the problem, I deleted the extension google pick account and it has been solved, it is possible that there is some type of incompatibility

1 Like

I have build the extensions with Makeroid and it is working on my Samsug Galaxy S6 with Android 7.0

Here is the AIX: com.puravidaapps.TaifunGoogleAccount.aix (3.0 MB)

@Taifun if you could add this AIX to your website, that would be great.

Note: This Extensions only works with Makeroid and not with other Distributions of App Inventor

@ivan_moreno thanks for letting us know the cause. I’ve got a hunch of what’s happening here, I just need to confirm with @Taifun.

I will try to create a component instead of an extension and see what happens then.

Can you optimize this extension? Or is that not possible?

You’re welcome, you’re doing a great job.

I imagine if it would be possible if another library of google play services was used, but I’m not sure

1 Like

Unfortunately I can’t do anything about this, see also chapter 3.2.3 of the Extensions document

… the external libraries (jar files) must be unique across projects. If a project imports several extensions, then two different extensions cannot import the same jar file.


yes, unfortunately after the latest Makeroid update the Google Pick Account extension is not compatible anymore with Makeroid, because both use the Google Play Services library. I will add a note on my webpage
Thank you @ivan_moreno for finding it out…


@ivan_moreno I need to confirm that the extension is causing this. Could you remove the extension from your project and try building again?

I already did, without the extension builds correctly.

you’re welcome, thank you for your excellent extensions

now it works ?

Thanks to @Taifun releasing the source code for this extension, I’ve just implemented this as a Makeroid component. It’ll be available in the next release. :wink:


Thank you :wink:

As advised by @Taifun, we’re going to be creating a component for this.

No problem, that’s great news :).

Maybe we can compile your extension with Makeroid, so that you can put it on your website

The source code of the Pick Google Account extension is now available on my webpage
You now could use that code to create a component out of it…