Error while installing APK on phone

Maybe you changed your package name or imported an app from another AI version (AI2, AppyBuilder, …).

1 Like

i don’t use other platform i started with kodular only.

i think the best way to find out is someone try this

I have tried and it works.

1 Like

It never compiles the app without package name as far I know, but his app is compiling without any problem.

APK is working on my phone without any problem without changing anything in your AIA, I’m assuming you are getting an error when installing the app.

Like that:

If you are seeing this error then:

  • Make sure package name is in the correct format if you have custom one; com.yourname.appname
  • Make sure you uninstalled the app first if you have already on your device. Then try installing the APK instead of updating/upgrading.
  • Make sure you have a device which has higher Android version than your app’s min Android version.

For example, if your app’s Min Android Version is 5.0 and if you are trying to install on 4.4 device, it won’t install the app.


However, there is usually no reason to change the package name.


This is one way users use to restart the app, so no issue there


1 Like

i think there is no problem just put package name in screen 1 and install.!

Yes, but if the permissions have been granted, the Notifier reappears and then you get into the infinite loop.

Nope, it just displaying a notifier which says “You are not registered to app.” in Turkish, and you when you press “Kayıt Ol” (means “Register” in Turkish) button, it shows a user sign up screen, so everything works as expected.

It will just display a notifier at first boot which says “You are not granted the permissions”, and when you give all permissions on settings, app will work. If you don’t give permissions, app will force you to give all permissions, so there is a loop in this app, but not infinite.

I changed the topic title for better understanding. Because there is no app loading error, this is just a installing APK error.

1 Like

Not what I can see


1 Like

Are we talking about the same app? I see this after I opened the app and granted permission:

screenRecording.mp4 (1.9 MB)

Important notice: On some new devices and / or with updated Google Play Services they are NOT installing APKS from builders due to Play Protect

You have to deactivate it and try to install again, generally it should be enough

This is what I see after I open the app:

Please give all permissions when installing the application on your phone.”

Same result on Android 5.0 without runtime permissions (granted at install-time).

Did you pressed “Retry” after you granted all permissions, because I don’t see this dialog when I granted all permissions in settings.

Yes, and why is it not working on Android 5 (without runtime permissions)?

I got it, I have to click 6-8 times (device dependent) the button TEKAR DENE until the registration appears. On Android 5, it never comes. Tested on several devices. video2.mp4 (2.9 MB) (Xiaomi Note 5, Android 9)

If, as a developer, I’m having trouble using an app, most normal users will enjoy the app for sure. :wink:


Yes same app however, now I’m getting this as well if I deny permission twice as well as check don’t show this again

Second issue, if I only deny permission twice, then app tries to open next screen but crashes


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.