Error while verifying Apache Ant install


And finally path ? post a screenshot

@Tekwizer it should be Path instead of PATH. Correct them

Done but still nothing


Open a command prompt window and type echo %JAVA_HOME% and post the result please


Maybe java jdk in not configured correctly and causes problems

@Tekwizer As far I am understanding , you have not saved your variable by clicking on Ok.
Please click on ok first then this window will be closed.It looks like

and then you will see another window something like this

Then again click on Ok then your variable will be saved
Then rerun your command

1 Like

I am clicking ok

also for better understanding pls take a look at this guide -

just try to restart and follow the steps in video

Try removing the spaces before and after the semicolons (;) in your path variable.

Also, make sure you restart your terminal after you make any changes to the environment variables.

However, like I’ve mentioned in both my articles, you should migrate to using Rush. Just like you might have experienced it now, setting up the environment for using AI2 sources and/or extension template could be a bit tedious if you haven’t done something like that before.

Rush solves this issue to some extent. Instead of having to download and install ten different programs on your machine, you just need JDK 8 and Rush to start building extensions. On top of that, you get a bunch of cool new features, like faster builds, direct support for using Android manifest, etc., when using Rush.

To know more about what Rush is and how to install it, head over to the following post :point_down:


Thanks @Shreyash :grinning:


I missed that cause I usually change settings from

and not from here

Thank you @Shreyash for your help


@Shreyash there is no path variables in mine PC , however ant command is working how is it possible if it is possible then I don’t think the problem was caused by spaces in path variable.

No way! The path variable must be there. Can you show me a picture that proves your statement?

Look here @Shreyash

Here are mine vars


and Here I run my command


1 Like

I can’t see all the variables on you PC in that picture. Anyways, there’s a much better way. Run echo %PATH% in CMD and paste the output here.

1 Like

Got it.
I have pasted the %ANT_HOME%\bin in my user variable instead of system variable but it is working

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.