Extrange behaviour with a deleted variable

Hi koders!
I have an extrange problem in my app. I used a variable that was a counter, when the counter reached 5, a interstitial add was displayed and then restarted to 0.
I had to change to two screens app because had problems compiling and the add begins to give problems; every five times the variable was used, the app get frozen.
So I deleted the variable, used a new one, make new procedures, etc.
Now the reset of the counter is make when the variable reach 3, but the app keeps crashing when this variable is used 5 times.
I had deleted the interstitial component several times and erased all the blocks related to this and making them again, but hasn’t solve the problem.
I can’t find where the problem is but it seems like some “phantom code” is remaining there and causing this trouble.
Is there any way of finding this kind of problems?
Any clue will be apreciated.

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

To get an image of your blocks, right click in the Blocks Editor and select “Download Blocks as Image”. You might want to use an image editor to crop etc. if required. Then post it here in the community.


This post was flagged by the community and is temporarily hidden.

your contribution is not really a contribution
therefore it has been flagged
and to edit and write exactly the same does not make it better…
if you really like to help, then provide a useful answer… thank you



i want to check it what i return to this topic, And i mistakenly undo the deleted post, its done by mistake don’t do flag again, it send me notification that i Used the undo method many times so it gives me 50 seconds cooldown and in the interval you gave me the another strike.

Did the ad work perfectly before splitting your app in two screens?

Thansk for answer.
The problem is the app has more than 8.000 blocks and I don’t have a clue of where the problem should be so I don’t know which blocks post. I was asking if could happen that something get “hidden” or “stucked” inside the code and if yes, if there is a way to check it.

Yes it did. It was showed before a procedure was called and worked fine. This procedure now is on the second screen, so I change the blocks so the ad is showed after the procedure is finish, before returning to the main screen, so all the necessary blocks and variables are in this second screen.
I have noticed that if I run the procedure two or three times and after that, close the app an open it again, the failure doesn’t happen. Only if the procedure is used 5 times in a row.
But the number five is nowhere anymore!

In this blog you have a sample aia. Pls check tat , It will solve your problem