Extrange border in card view

Hi Koders!
I have a card view with a transparent colour that is shown with a darker border and I don’t know why this border is appearing. Is the one marked with a red arrow in the first image.
This border is shown when the app is running in a device, but not in the designer. Besides that, the border is shown in some devices but not in others.
The configuration of the card view is the one posted.
How can I get rid of this border?
Thanks in advance!

Try setting all paddings to 0

Try decreasing corner radius.

Thanks for your answers, but I need that padding and that corner radius.
Any other idea?

What happens if you set elevation to 0 ?

Set all the paddings to 0 then use arrangments and space to arrange all of the components then design what you want to design.

Ok, I’ll try, but if this is the only solution, this must be a bug or something.

No it’s not a bug. If you want to achieve this on android studio then you don’t have to use that many component but then you’ll need to understand xml

The main reason for this is your background color. Set the background color to #000000FF or set elevation to 0. If you used any color under elevation, you will see a border like this behind.
If not working with other methods, then the final option is that you should use solid colors as transparency in the background color is also a main reason for shadows behind.
Don’t use transparency in the background color.
:+1: :+1:

Ok, I’ll check this solutions, but I think that should be possible to use transparent background color and elevation in card views without this borders, so I think this should be fixed.

1 Like