FileTools : Some tools to work with files

Currently you can use the shell component to execute commands such as cat /proc/cpuinfo to obtain info about CPU. You can google everything about that. Anyway, that is a bit off-topic, so please open a new topic if you want to continue this conversation.

@vknow360 hello… :pray::pray:

Does this extension work in Android 11?


1 Like

My file directory is /Android/test.txt
How can I read it?

starting with the SDK30 release, which should be available very soon you will not be able to read from/write to an arbitrary directory anymore…
this will be restricted to the ASD - application specific directory and shared storage

so the answer to your question is: you can’t


1 Like



I want to copy files from App assets to enternal storage, so how can i do it?

What have you tried?

are you talking about the the internal (emulated) sdcard?
starting with the SDK30 release you only will have access to the ASD and shared storage but not to any arbitrary directory on the internal (emulated) sdcard anymore…


I want to copy files from Assets Manager to Internal Storage…:point_down::point_down::point_down:

How can i do it…?

you can try copying from regular “file” compoment then make anything
but i know as it not support too :frowning:

1 Like

Show your blocks and tell us which Android version you are testing on.

Last modified time not working

Which android version you are using ??

Try to use join block file:// Infront of the pathway

1 Like

file doesn’t exist
lack of read permission
no access to external storage (Api 29)

1 Like

Android 9 version

On screen initialise gave read and write permission,

File exists , iam able to open that file from the app on same screen but not getting modified time

Tried but not works

Actually what you are getting?? File modified time? Then try this shell command

Post an apk. Also tell how to produce the error.

While creating apk i found that

It works with
file:///storage/emulated/0/my file.pdf

I think yesterday i missed ‘/’ infront of path while adding file://

Still “do it” result while using creator shows 1.1.1970 but works on apk

Thanks for helping

Thanks it works

1 Like