Filey: Encode and Decode Files

@peter please suspend this balaji_developers account, i think he lacks manners and should attend a class to learn manners first

Edit : As much you are using abusive words, you are inviting trouble, and it is affecting, also you have showed how characterless person you are :stuck_out_tongue_winking_eye:


One more great and free extension by @vknow360. Keep it up great work :clap:

1 Like

For me, using App Inventor, Filey doesn’t want to recognise /storage/emulated/0 as a file path, have to convert this to /mnt/sdcard. Other than that all works well :+1:

1 Like

It worked on Memu with that path.Probably it varies with devices.
You can use GetExternalStoragePath block of EFile extension to get correct path of external storage.

1 Like

OK thank you :wink:

Which device and which Android version?

Actually, this path /storage/emulated/0 should work on all Android versions. I’ve tested this on dozen of devices and all versions of Android. Of course I don’t know the source code of this extension, but I can’t imagine that @vknow360 should have changed anything here compared to his other extensions.

1 Like

Actually this extension works with absolute file path.

Was on my Genymotion Emulator Android 9, running companion. Juan’s extension uses " / " and works fine. Tried that and file:///storage/emulated/0/file but neither worked…

Takes too much time.

One more reason the path /storage/emulated/0/ should work.

I don’t trust Genymotion and other emulators. I always test on real devices and don’t know of any device or Android version on which this path does not work.
And I’m still waiting for someone to find such a device. (I’m pretty sure there isn’t one.)

Genymotion Emulator Pixel 3XL Android 9 :smiley:

As I said, I am talking about real devices.

Can you check the external storage path using an appropriate extension?

On a (real) Pixel 2XL (Android 11 Beta):


Can you add a block to load Base 64 string to a Image component or layout backgrounds?

I used your fileTools extension to deliver the file path…getting Directories, then Files

Tested through companion on my Android 7 (real device) and /storage/emulated/0 and /mnt/sdcard both work. I don’t have a newer “real” device to test on.

I will think about this.

Strange :thinking:


Ran a few tests this morning.

/storage/emulated/0 is now working :smiley:

must have been some cruft laying around in the companion which has cleared itself.

How can i know which type of file is decoded?

This post was flagged by the community and is temporarily hidden.