Firebase storage download working for few android version but not working for Android 7 and above

Did you ask for write permission

1 Like


This many ways i tried and it is working for my android 6 mobile but not working for higher version mobile. Even in higher android upload image is working but only download is giving error about could not create folder…

And that’s because of this, you didn’t


@shubh_patel We already talked about this topic / question in this thread:

As you can see in the first block from @agc_softwares, it is asked for WRITE permission:

So please read the posts.


If so try using this; file:///mnt/sdcard/myapp/ and don’t forget to ask for permission as;


This path is working on all Android versions: /storage/emulated/0/

/mnt/sdcard (Android < 4.0)
/storage/sdcard0 (Android 4.0+)

The “/storage/emulated/0/” folder does not really exist. It’s what might be called a “symbolic link”, or, in simpler terms, a reference to where the real data is stored.

Please see attached blocks i tried but showing “Could not create a folder to store down load”

Try using it like this


and also use this path


Thanks a lot now it is working with input 1 and 3 text input…



Yesterday my app was working and today i added loading butoon and some background color view change but now when app starts it is giving message"Error908: Thepermission WRITE_EXTERNAL_STORAGE has been denied.Please nable it insetting app."

Please guide where i have made mistake.Even i tried with new app only having block when screen initialise it will askpermission but there also it is giving same error.

Block is attached here.

That makes no sense at all, so post the aia.

Shoppingpointbyshubh.aia (130.2 KB)

Please find attached aia

Try this one: Shoppingpointbyshubh_2.aia (126.3 KB)

EDIT: Cause of your problem is that there is no WRITE_EXTERNAL_STORAGE permission declared in the Manifest. Therefore this block cannot work:

So that a permission can be requested, it must be declared in the Manifest.

As a workaround I added the File component as a dummy to get this permission in the Manifest.

I tried like attached but this is also not working.
I have my previous .apk file can i use it kodular again?that is working

Where is the problem? Do you have another permission issue?

Try this one: Shoppingpointbyshubh_2.apk (5.8 MB)

1 Like

This is working…
Please tell what should be corrected…

My aia doesn’t work, because of the issue that the screen folder (src) is not included in the aia when exporting it.
So add the File component (as a dummy) to your project and build the APK. That will work.

… this:

No blocks needed (only to get WRITE permission in the Manifest).

1 Like

Sorry for late reply i already tried and working.

Thanks a lot for your support