Bug on WriteExternalStorage Permission - Not Working

I’m using Android 12 phone, also I tried it on Android 11 phone same problem occurred. The permission is automatically denied when i click allow. The app says permission denied. Please help me. It’s not working today, but yesterday it’s working properly. I thing it’s a kodular bug.

  1. WRITE permission no longer exists on Android 11+ since targetSdkVersion = 30 (Aug 2021).

  2. WRITE permission must be declared in the Manifest so that it can be requested on Android < 11. This means a component or extension that requires (requests) this permission must be used.

  3. There shouldn’t be any way to grant this permission on Android 11+.

So answer which component and/or extension you are using. In any case, however, WRITE is not granted on Android 11+.

1 Like

Now how can I create folder on external storage, please give me a tutorial i’m new.

I’m also waiting for this answer. maybe there is another way that is an alternative

On Android 11+ you can only create a folder in one of the Shared folders (like /Download or /Documents or /Music. This does not require WRITE permission on Android 11+.

Here is an extension that declares READ & WRITE permission correctly on all Android versions:

Try this APK on your Android 11+ and Android < 11 test devices:
declareReadWritePermissions.apk (5.2 MB)


This also not working in my case, I try to create folder /Pictures/MyFolder/filename.jpg

But it’s not working. :cry:

Show your blocks.

Try this one:
declareReadWritePermissions2.apk (5.2 MB)


Yes, there is another bug with the File component (the same as with AI2).
I’ve pointed out this bug countless times! :upside_down_face:

Now I try to download an image into my Android 12 phone. But It’s not work, I try with another download extension also not work. Image not download the error occur 908.
Here is my blocks:

associated with


I tried this simple code block. Uploading: Take_picture.png…


the result : Error 201 The Cammera did not return an image

Use my extension (Download to ASD), download the image to the ASD and move it then to the Shared folder using the TaifunFile extension. Both don’t need any storage permissions on Android 11+.

works for me, thanks

1 Like

@bodymindpower sorry to mention you i have a download the storage permission effects the apps that download some files to users download foler beacouse some of the apps still working…its just my doubt can you please clear it?

as always, an update with errors … everyone writes about errors

:question: Unclear.

My app is about to download some files to user device is this effect the app??

Unclear. Show your blocks.