Firebase Authorization

Read this guide:-

You should give us enough information to help you.

there is not a lot of info, 2 days ago i could create users from my app in test mode with the companion, now i get the error firebase authorization not working in the companion, i then tried to build the app to run the apk from my phone, cant do that either.

Here is the LOG file while building the app:
i cant build my app either this is the error i am getting

Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/…
________Creating listview xml in res/layout-v21/…
________Creating xml in res/drawable/…
________Creating splash png in res/drawable/…
________Creating colors xml
________Creating strings xml
________Creating styles xml
________Creating drawables xml v21
________Checking for firebase
________________Firebase components found.
________________Firebase config file error.

Here is your problem.Check configuration file and download latest configuration file and upload it to assets.

First off, I think this alert is pretty clearly worded.

Secondly, for the compiler error, make sure the package name in the config file matches with the string in Screen1. It is most probably just a package name mismatch.

where do i download them?

Read this guide :-

I am wondering how this is possible

If you have not Configuration File (google-services.json).

@ttat_store did you read what I wrote?

yes i did thank you, that error message is after the update of the companion it SUCKS now i have save the apk to phone every time i want to test to see if it works

It makes sense, considering Authentication is a security feature.

Hi vknow,

first of all thank you for the guide, my app is not using google sign in it uses user email and password, i use it this way for a reason so i can keep track of my users.

my Json file is loaded on assets latest one did it this morning


After looking at your log I found that:-

  • Splash icon is creating error
  • List view is creating error
  • App icon is creating error
  • Some firebase components are creating error
    If this does not works then try @Kanishka_Developer this post:-

Only this is true. And I’m 98% confident with my diagnosis, as I myself ran into this error while trying to help him. The custom package name is to blame.

1 Like

Verify the package name in the project and in the Firebase Console

That solved the problem for me

1 Like

this is my app package name screen1

this is firebase correct?

Your screenshot doesn’t show us your package name. Select Screen1 in the components panel.


Package name is still not visible. Scroll down in the panel till you find that property.

let me send again

i see mine is blank let me check that sorry

Paste the package name from Firebase Console there.

do i have to past the whole one or part, i have done all not working.