Firebase Error Permission Denied using Firebase Authentication

firebase-auth
(Carambel) #1

I am using the recently added Firebase Authentication feature, it is almost different to the extension already seen by the Thunkable community.

URL: Firebase Authentication - Kodular Docs

I have followed the steps of the Kodular guide to use this function, but I get an error and it does not register, or I am not seeing the error, sorry.

image

The rules are in “false” since when using the authentication it would be incessant to put “true” since there is even news that there was theft of information from Firebase Database that had the condition “true”.

0 Likes

(MeteorCoder) #2

Glad your English is good! We need more people like you…

As for your problem: Firebase auth Common properties not showing

And as for your other problem: How to Remove Activate Windows 10 watermark permanently 2019

:point_up: You’ll need it.

3 Likes

(Carambel) #3

Hi, thanks for the help.
Unfortunately, I have not been able to solve the problem, this message is bounced “The given sign-in provider is disabled for this firebase project, Enable it in the firebase console, under the sign-in method tab of the Auth Section”.

The option “Email” is activated.
I have uploaded the google-services.json file to the Assets folder and it keeps showing the access error.

0 Likes

(MeteorCoder) #4

Can I ask, based on the screenshot you added… Did you change your project name? From project-whatever to something you want, like your apps name. Can you tell me, is this built or companion?

@losasencio You alive over there?

1 Like

(Carambel) #5

I have not changed anything, but this happened.

I can not operate the user registry with Companion, but when I export it in APK, you can register new users.

Result:

  • I can not test the application by Companion.
  • Users can be registered only if it is exported as APK.

The only bad thing is that it still shows the Permissions Error. (Maybe you have to rewrite the rules?)

1 Like

(MeteorCoder) #6

Let me take a minute to look at your screenshot.

What error does it show, screenshot, log, any piece of information is vital.

P.S: While doing this I’m currently trying to make a meme from Ruby :joy: Take a look:

Look a bit closer and you’ll get why it’s there.

Also try following Understand Firebase Realtime Database Rules  |  Firebase Realtime Database  |  Firebase.

1 Like

(Carambel) #7

Sorry, but I did not understand the reference of your meme, I could explain it causes me a lot of curiosity.

I will wait for you, although I will be experienced with these prefabricated Firebase rules that I found on GitHub.

0 Likes

(MeteorCoder) #8

It’s installing pacman-5.1.2-2-x86_64 :joy: :rofl:

0 Likes

(Carambel) #9

The closest thing to expressing in English, since I speak Spanish, would be this: “lol or wtf” (In a good way)

It has worked for me, I hope it works.

{
   "rules": {
     ".read": true,
     ".write": "auth! = null"
   }
}
0 Likes

(MeteorCoder) #10

So did it work? Or did it fail? In English, we put what happened after the wish/hope/thought/the thing that’ll must likely fail :joy:, so i solved your issue then, correct?

2 Likes

(Carambel) #11

Yes, you helped thank you for everything, luck with pacman. :V

1 Like

(MeteorCoder) #12

LOL, thanks. Now just press the check mark on my post about the Pacman since it contains the solution. If anyone asked, I never told you to do that :joy:

1 Like

(Felipe Valenzuela) #13

por lo que entendí, ahora puedes dejar tus datos privados? si es así, como lo lograste? yo me autentico, y si pongo “.read”: “auth! = null” en las reglas, igual no me deja leer.

0 Likes

(Carambel) #14

Al final tuve que cambiarle por
Lectura = Verdad
Escritura = Verdad

Ya que cuando el auth funciona ya no te muestra el error de seguridad, y si testeas tu app desde Companion no lee la base de datos, para la lectura de la base de datos se debe compilar la aplicación en APK.

0 Likes

(Felipe Valenzuela) #15

si se que la app debe estar compilada, ya que no funciona en el companion, pero entonces igual hay q dejar la base de datos publica para poder leer/escribir?

0 Likes

(Carambel) #16

Si, de esa manera evite otros problemas que se me presentaron.

0 Likes

(system) closed #17

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes