Firebase Tag List

Describe your issue

Event Firebase Tag List doesn’t get triggered

Steps to reproduce the issue

Screen1 initializes and call Get Tag List block and then nothing happens

Expected Behaviour

My Firebase is empty so I expect that value variable at Tag List retrieve an empty string or () at least

Actual Behaviour

Nothing happens

Show your Blocks

Android version

Tested it at Android 8.1.0 Smartphone with 4g connection and Nox Emulator through Wifi

Firebase Tag List is a list so use ‘Is list empty’ block.
This one:-
Screenshot_2019-06-05%20Kodular%20Creator(1)

3 Likes

Still not working, the event it’s not getting triggered I guess.

Try using ’ for each number from’ block instead of ’ for each items in list’ .

But this block should be used after the DB it’s written, that other block simulates the first use of the app.

Can you elaborate more?
I am unable to understand.

The process initialize with the block “Screen1 initialize”.
If Firebase has no Tags writen it should display the message at Label19 text but nothing happens.

Firebase is working fine.
Something is wrong with your blocks.
Can you send APK file?

Don’t know if you noticed, but i’m using 2 Firebase.
The blocks from Firebase are working fine, I’m receiving your data, but the other Firebase_indice_oficinas is not, I’m getting nothing.
The curious thing about it it’s because both Firebase elements are equal.

Try one firebase instead of two.
Also use a notifier to show that data is saving (for testing).

Done that but still doesn’t work, when Firebase is empty, the event Tag List doesn’t get triggered.

Amazing…
Firebase is working from my side.
You can try any one of these:-

  • Delete all blocks and rebuild with a fresh idea
  • Import .aia and load it on other builders
  • Use any other Firebase Database
  • Use other databases like airtable,mysql,php
  • Delete project and make new project from scratch

Does the list start with number 1 if it is so you should make the list start with a number larger or less than 1

Tested the app into an Android 6.0 device and it worked fine, Android version issue I guess…

I have also issues on different android versions.
On Android KitKat my app shows runtime error but on Android Nought it is showing blank screen.