FloorAmount.toUnderlyingValue()' on a null object reference

After Kodular Fenix 1.5.6 update without any changing block i build project file and showing this error

attempt to invoke virtual method java.lang.String com.google.appinventor.components.common.FloorAmount.toUnderlyingValue()’ on a null object reference

Kindly help how to fix it.

Are you testing in latest companion?

@Still-learning op is testing apk

i have the same problem since the companion was AUTO UPDATED how to fix it ??? please
Starting the Companion , notif from playstore to auto Updated and get error while using Companion;

Companion 1.5.5 worked aswell.

the same Error message into the APK

In order to indentify what causing the problem, which components or extensions do you use in your project ?

im using taifun tools version 18 and countdown timer from deephost V1

iComponent used:

  • airtable
    -baner ad
    -inters ads
    -start app banner
    tiny DB

Apologies for the inconvenience. This will be fixed in the next release. Till then, you can do the following to fix the error:


Thank you for your Response

Still the same after deleted interst ads ?
Need to delete all Google ads ?

Use blocks to set it

Where are the set this block? Any examples?

The image is the example. You will find the block in the drawer for the Ad Manager banner, interstitial, and rewarded video components.

Also see this for context on where to place the block

ok XD

i have just removed all google component

answer was just here

thank you @dora_paz and @Vishwas for the link


This is Right block or Wrong?

1 Like

That’s right. You can also set the eCPM floor when the screen initialises. Anytime before loading ads, basically.

1 Like

Okay thanks! Today I’m updated my all apps and checkout the eCPM!

Can you tell me Facebook or Unity SDK Outdate, SDK Update in this Month? If yes then which Weeks?

I’m set my block! May be I’m going rights?

yes…its working

wonderful, everything working with this modification.

Still the same …

re add and still the same , got errors

i don’t load interst ads , is it the error?