Font Awesome icon is not showing in App

In Font Typeface …we have Font Awesome also but Font Awesome icon is not showing in App . I tried with 2 way

One from text and another one from html text decode block .

Show what you did?

1 Like

You say icon is not showing…
Do you still use the correct icon path or Name?!

You can use this cheat sheet to know which pieces of text you need

https://fontawesome.com/cheatsheet

You can see here now I am creating menu and here I am using from material icons …I am here unable to show font awesome icons . I used cheat sheet also from two 2 that I mentioned above

1 Like

Yes …i already used font awesome icons on thunkable and appybuilder

I know about this one

I want to see how you did it in the blocks or designer.

I’ve just done the following and the icons are showing for me.

In designer set Font Typeface to Font Awesome:
image

Blocks:
image

You can find the codes here:
https://fontawesome.com/v4.7.0/cheatsheet/
The codes you need are in the [brackets]

10 Likes

Thanks semicolon ( ; ) was missing in my block .

2 Likes

you can do it like this too… its very simple and you dont have to use any block

just select your lebel and enable HTML Format option in Advanced Section

and use fontawesome cheatsheet code directly on the lebel text.

5 Likes

This post was flagged by the community and is temporarily hidden.

:black_small_square: Its better you write the font code in the Text column in the label component.
image

:black_small_square: and then choose “Font Awesome” as the Font Typeface.
image

:black_small_square: and after that just tick the HTML Format option in the “Advanced Properties” column rather than doing anything in the Block section.
image

Thank You.
Hope it will help you :wink:

2 Likes

It Tried This Method But it’s not working

FontAwesome.aia (1.1 KB)
use it on label for good results
Note: If you want to make an action using this label make sure “Clickable” box checked


FontAwesome.aia (1.1 KB)

Previously I used icons in my app with a specific font, but in kodular I’ve decided to use FontAwesome and I realize that not all icons are displayed correctly in the application, even the same icon that if displayed on a screen, in different screen is not displayed.

I have already done the steps described above, as I said before, I already used a specific font for icons and it is not complicated to configure them.