[Free] Fetch - A powerful and simple download tool

great… what about providing a screenshot of your solution? Thank you…
Taifun

Like I said, it doesnt work built into APK. It works ok in Companion, but not as APK. Shitty situation… :frowning: Probably need to dig deeper into AIX source (if Mr. Kumar provide it) and lib sources…
Btw, Taifun, do you think you can add progress reporting to your zip/unzip AIX? I unpack large files in my project, would be good for UX to see the progress… :slight_smile:

Here is another test APK that downloads the 100MB bin file to the Shared folder /Download or to the ASD. Check it out and report back if you find any issues (name the Android version & device).

Fetch_DownloadOrASD.apk (5.5 MB)

If there are no issues, I’ll post my blocks.

I just see that I temporarily disabled this block. So if someone wants to test with APK on Android < 11, he/she needs to go into app settings and enable storage permission.

In your APK both download destinations work for me.

But I would like to point out that my download destination is not /storage/sdcard0/Android/data/package/files (so called ASD) but the app internal storage /data/data/package/files to prevent user manipulate the files. In Companion this folder is redirected to /storage/sdcard0/Android/data/ package /files for debugging purposes. So we are talking about little bit different scenarios.

Try this: Fetch_Download_ASD_PrivateDir.apk (5.5 MB)

2 Likes

Works like charm! 3 sucessful loops! I think the time has come, my dear Anke, to share your secret. :slight_smile:

EDIT: during the download notifier says: “file does not exists or is a directory”…

I’m not getting this message on my test devices.
Which Android version and which device?

Post a screenshot of it.

Android 10, device M1804D2SG.
I tried to reproduce, but ufnortunatelly (or luckily? :slight_smile: ) the error doesn’t appear again. I’m looking forward for you blocks. :slight_smile:

It happens when you change checkbox option choices during download

2 Likes

Yes, I should disable the checkboxes during the download.

1 Like

Yes, confirmed. But its a marginality…

Here are my blocks. Since I used a lot of labels for didactic reasons, the code looks a bit bloated. (This can of course be made much more compact.)

2 Likes

Can you unpack path and path2 procedures? Whats the magic inside? :slight_smile:

Well, end of all talking. I did another loop of testing with manual path input and can say: there are serious bugs. At least when used in AI2. The bad part about the story is, I have no other option? Can somebody reccomend another extension to manage download similar way (resume, progress reading)?

EDIT: finally got to read bug reports on github :)) well, Fetch library is literally FULL of serious bugs, lot of them related - surprise! - to download problems. :)))

One week of my life gone tring to solve this sht… oh my goodnes… :smiley:
And here we go: this is what Im talking about all the time and Anke denies that:

image

or

image

and finally:

image

Game over.

I migrated my project to AI2. Here is the APK.

Try it and tell us if it works for you (with all paths).

Fetch_DownloadOrASD_AI2.apk (3.4 MB)

2 Likes

Pf… I dont understand this. Anke’s APK works smoothly for all paths on same device. The good news about it is, there’s a light at the end of tunnel. How are the path and path2 defined? This could be the only difference from my project, cause I use .file.makefullpath. I also tried build my APK in both AI online and AI offline (v 3.9 - 28th Jan 22) to see any difference - no difference, same behaviour.

Post your blocks and a test aia.

And if you use AI2, migrate the project to Kodular and also post these blocks and the aia.

Can you pls unhide your paths? To let me copy paste your solution and test?