[Free] Fetch - A powerful and simple download tool

What’s the problem with posting your blocks and aia once, at least for Kodular?
Because we’re on the Kodular forum here!

If you are looking for a solution for AI2, you should ask there.

Anke, why do you hide from us part of your code, especially when I positive confirmed it work for me? Why don’t you share it with us? I really don’t understand your way of troubleshooting - had never seen somebody on stackexchange for instance, hiding part of the code in the answer… There are 2 options: you want to share the code or you dont. If you dont, I will send you a flower of roses (I travel to Bielefeld occasionaly, which is close to your place :slight_smile: ) and shut this topic down. I got many better things to do then convincing you about documented bugs in abandoned git lib. :slight_smile: As simple as that, believe or not.

I’ve put a lot of effort and time into clearing things up (on AI2 and Kodular). And you don’t respond to my simple request to post YOUR blocks and aia (at least for Kodular).
Instead of providing something yourself, you complain about it. :upside_down_face:

Well, as you wish… your choice. That settles the matter for me.

2 Likes

And we all appreciate your afferots, Anke. To make us happiest people in the world, the only thing missing, are you mystery path and path2 blocks. Are you gonna share them with us or not? :slight_smile:

Are you going to share your Kodular aia and blocks?

If not, then what have you got to hide?

1 Like

No Im not. I tried Kodular - it doesnt even communicate with companion (latest version from Google Play). Im definatelly not interested into troubleshooting Kodular. I have lot of headache with Fetch. I dont need to start another one week loop talking about sht why Kodular doesnt work. I just kindly ask for two fcking lines of code. And there is one woman, who knows the solution and keep it secret, because… I really dont know why. Never ever had such experience. And at the end everything turns back to me convincing me Im not cooperating enough. :smiley: Holly cow…

Yet you demand others help you and show you their blocks etc. It’s up to them if they want to help, but going by some of your posts you seem quite rude so I’m not sure why they should.

1 Like

In the begining one of the first answers was complete denial of the bug:

Does it make sense to you? “I tested and because it works for ME, its a proof, theres NO bug.” :smiley:

So I think I kept calm for a long time, because facing such denial of logic is really hard to stay polite. :slight_smile:

Cheers.

That’s a weakness in your character and failure on your part as it’s you who chooses how to react to others.

This will be my last post in this topic as I don’t want to derail it.

1 Like

Nevermind, the important information for others is, there are unresolved issues with Fetch and if you want someone to share not just 99 % but 100 % of the solution, you have to show something. Post a blocks which doesnt do a job over and over. Or maybe something else, maybe make a dog sound: woof woof! :smiley: And yes, youre right. it was my weakness I havent recognize this master-slave game at the very beginning. But now I’m well trained for next round. Cheers.

So you would like to have a solution for AI2, then, as Anke already said, you have to ask the question there and show what you have already tried (ie at least your blocks).

We are here in the Kodular community.

Is that really that hard to understand?

And if you (for whatever reason) can’t work with Kodular, then why are you asking questions here?

This is crazy :smiley: It looks that this platform is a kind of kindergarten more than coders platform. :smiley: I really dont understand whats so hard to understand, there is plenty of evidence the Fetch library is buggy. So building an extension out of it logically produce bugs. There’s no simple miracle to happen like rearranging blocks. It`s similar to another extension where I found a bug in using int var instead of long which caused overflow and wrong readings from progress counter. I reported to the author, and he repaired sht in few days. This is how it should look like, not screaming “theres NO bug, theres NO bug!” like someone else did above. And yes, I gave a donation to this noble young man, who maintains the product built my himself. Take care…

I agree

However

  1. you are asking in the Kodular community but you are using App Inventor… the environments are too different to expect the same result…
    Your are asking in the wrong community and therefore it is a waste of time for everyone here trying to help you

  2. mind your language and be respectful… always…

Taifun

3 Likes

Yeah, youre right. Take care and keep up good work. :slight_smile:

1 Like

Hello there.

This is such a helpful extension, but may I ask a question, please?
How do I arrange my blocks for this “Fetch” extension to be able to download a .mp4 file from OneDrive through WebView?

Thank you.

@Sumit1334 This Extension Support Muiltithred Download Yes / No

Networking operations are always done in a new thread.

This is the one I have been looking for.

But may I ask the developer what kind of permissions thia aix need?

for android 11 does it require permission MANAGE_EXTERNAL_STORAGE

can you provide a doc

I am not much familiar with this permission. Even I haven’t added this permission in extension manifest. AFAIK you don’t require any permission in android 11 until you download your file to ASD and scoped shared storage like Downloads, Documents etc. However, you could ask the WRITE_EXTERNAL_STORAGE permission own in lower version devices where it is required (Maybe API < 29). I don’t know exactly. You could look here for more info about storage and permissions.

1 Like

I added this part to my guide:

Storage Permissions on Android 10 & 11 - EDIT (May 11, 2022)
Since Kodular & AI2 decided to declare requestLegacyExternalStorage=true in the Manifest (which is only ignored on Android 11+), storage permissions must also be requested on Android 10.

If you remove this from the Manifest, which I would recommend, no permission for the Shared folders would be required on Android 10 either. The storage permissions would then have to be declared as follows:

<uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE"/>
<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" android:maxSdkVersion="28" />

I generally prefer to request as few permissions as possible.
I don’t like permissions and my users even less.
:wink:

3 Likes