Google maps and notifier

Hi, I am trying to show a notifier after my location is enbaled for google maps but it doesnt show.

My block are these:


So when its the first time to open the app the system ask me about the permisson of location. It is ok so far but then when I open it again the notifier just dont appear. As you can see the location enable is true but ir doesn work, If I test it in companion and click in do it it works perfectly.

Whan happen? Am I doing something wrong or what? I try to show the nofiier in a normal way and it works ok too.

Also I tried to add a clock to fire the notifier after the conditional but it still doesnt work.

1 Like

Try to store the value of the “my location enabled” block to a variable and check if the variable is true at the start of screen or app. The clock idea is good, but you have to delay WHOLE condition, not the notifier.

1 Like

use the = block to compare my location enabled = true

1 Like

It is the same result, it doesnt work :slightly_frowning_face:

I tried to store the value but dont store. I do a conditional if the location is enabled so set a variable to true but the value dont store and the location enabled is true.

I do the same process with a different conditional and it works perfectly… is there a kind of bug with this location enable of google maps??

  1. Check if MyLocationEnabled is true on start.

  2. google_maps2

Look the location enabled is true but store false in the variable.

If I click in do it, the variable store true :confused:

It’s obvious it doesn’t work. AT START you can’t check the condition. IT TAKES TIME for the google maps component to load, that’s why when u CHECK THE CONDITION AT START it’s a false. You try to check if location is enabled before the location API loads in your app.

So, you have to start clock at initialize and in the CLOCK block check the condition.


In other words, you have to delay the checking part, but u just fetched the variable at the start and returned it into clock component, which is the same as u do earlier.

1 Like

Thank you man, It works as you said

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.