Help - API Get Error in Kodular

Hello Koders.

I am unable to fetch this api :-

I am getting this error

This is my block.

Am I doing anything wrong?

Things I have tried…

  • Used several versions of Android, from 4.4 to 8.0, still same error
  • Tried Http version of another API, worked, but https version of same API not working too.

Anyone else having these issues or is it just me?

First things first have you tried that exact URL on your device browser and it works?

There is not an issue with HTTPS as a whole because it is used by 10k’s of other apps.

The 1101 Error means

ERROR_WEB_UNABLE_TO_GET; That could mean that it requires a POST and not a GET.

If you use alot of API’s I suggest you get Postman. It is a great tool to use to connect to API’s see the debug issues and make sure your URL’s are accurate.

Yes it works perfectly well in my web browser. I don’t know what else to do:sob:

Error 1101 shows that WEB was unable to get a response which can be due to several errors like internet connection,POST,PUT,etc.
It also happened with when I tried to use NewsApi in my app.It worked perfectly on Android 7.0 but not on Android Kitkat.
But other apis like Bitly or RestApi works fine on all android devices.
Can you send me apk ?

Try it in Webviewer and see if it pulls up.

That tests the device and OS and keeps the component out of it.

This is the apk…TRIVIAgAME (13).apk (4.2 MB)

This is the aia…TRIVIAgAME.aia (22.7 KB)

Sorry I’ve been tinkering around…

works in webviewer perfectly

Sorry its a bit different from before, I had to keep working on the other parts of the project. The response label is supposed to change to responseContent when Web1.Got.Text.

I have been trying different variations of the API with no success using Web1 component.

Is there a way to get the API response text from webviewer?

Web Component is working.
It loads response content on Android Nought.
I decoded question and correct answer but I was unable to decode incorrect answers because it shows ‘Argument must be valid JSON’.
I used JSON Tools.

Thanks for helping out. I was able to decode a sample of response and get the data I needed. Majority of my users are using 4.4 to 7.0​:persevere:…is it possible to get the text from webviewer?..or is there any extension that can be used as alternative to Web1 component?

Thanks @vknow360 for your help.:grin:
It turns out using virtual devices instead of real ones for testing may partially be the cause. Partially because it still fails to get data on real devices running kitkat Android 4.4 and some devices running 5.0. Hope kodular comes up with a fix.

Thanks house.

You mean App is working on Emulator but not on Device or vice-versa?
If yes then I am also in that category.
My one app works fine in live test but not on Android Nought.Also on Kitkat it shows a runtime error.
Is this a bug or something else?
Do you know @cian ?

I meant API won’t fetch data in emulators. I use genymotion with Android version 7.0 and 8.0 and bluestacks with android version 4.4. I don’t use companion app for testing.
Api will fetch data on real devices except 4.4 kitkat. Kodular please look into this. This is the api

Sometimes Web component gets data and sometimes not on KitKat.
It does not gets data from NewsApi.
And it gets data from Bitly Api.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.