Help with Google App Script

Hi, I am trying to use this extension. I did everything as he told but I am getting an error.
I contacted the extension developer and we both couldn’t understand what is happening.
As per his tutorial, I create a spreadsheet, copied his scriptcode and pasted on mine and deployed it as a web app. Then I copied my Script ID into the extension properties but it gives an error. I even downloaded his sample .aia file and placed my script ID there, still it shows the same error.

So I am assuming that the problem must be in my script code? Can anyone help me?
The extension:-


The error I get:-

My script:-
https://script.google.com/d/1_cj2wyYFinIAY7ynb-uIFjn5RujNlP10Znz2JKcljHltGX0Mpq8z_XN_/edit?usp=sharing

Does the sample aia work with his id? So as it is, nothing changed?

yes, it works with his ID. But not with mine. He also said that other 3-4 users reported no problems.

So to get things right. When you use your id, your script will be used. So the problem should be in the script right?

I think so, But he uses the same script. I downloaded it from his link.

I see he updated his download section today. Did you use the latest script?

Here is a screenshot of our conversation

yes I did, after he told me.

It is hard to say what is wrong. Your id is not defined says the error. So did you follow all the steps? Maybe start fresh and see what happens. It looks like the error is on your side since the sample app works.

So weird… I am working on this for past 6-7 hours… The chance of the error being my fault is very low coz I didn’t have to do anything… just create a spreadsheet, copy his script into mine, replace the url with my spreadsheet url, deploy the web app, put that script id into extension.

Anyway, since there is no other way to access spreadsheet (airtable, firebase, no thanks), I have no other option. My head is throbbing.

Fun fact: If this worked, I could have finished the whole app in one day.
Guess things don’t always go the way we hope it to…

Show an image of the script you made please.

Please go to this link.

Then maybe the error is in your spreadsheet. Using different headings.

Nope, doesn’t work. I typed the exact headings he showed in tutorial.

Uh… I deleted everything and did it again once more. Now it works. Weird…

1 Like

Hey… I didn’t catch the error may be it was due to the improper deployment of the script. Coz as i told you not a single user instead of you has reported me such error. And i have also deployed this script again to test this but i also didn’t get any error.

Somewhere there was probably a bug. Great that it is working.

1 Like

Hi, I faced different problem. in my case the example you gave was working properly but when we insert a new column, the app did not take into account the new column. could anyone help.
thanks

Have you deployed the script to a new version after making change??

I forgot to deploy to a new version. it work fine. thank you very much