Hide objects overflowing the parent Card

I am using @yusufcihan extension to create card views. Overall working great but one thing is bothering me is that a card, which is created inside another card is overflowing the parent.


You can see the date card is overflowing. How to hide the excess area, like in HTML there is option for OVERFLOW : hidden
Moreover I am unable to download the blocks as png or an image to show here. I am using Firefox if there is an issue here to download the blocks as png.

Did you adjust the height of this object?

Yes I have tried that. When a card is created in another card, it auto gives it margins as well. We can remove the padding, but not the margins.

Instead of card view inside card view , you can use Vertical Arrangment only.
I have never faced this problem. :expressionless:
Might @yusufcihan can give some light on this :thinking:

2 Likes

You can use decoration component for setting padding and margins of any component (Visible)

Exactly

Well, @oseamiya I don’t think this issue is caused by extension so you are tagging extension’s developer​:sweat_smile:
The problem may be in the margin as far I think
@Sarmad_Khan you should set the margin of card

1 Like

you should set the margin of card

Ok @Sumit1334 I am using margins now to move date card to far left to avoid making it look ugly, but still I wish there was a similar option.
Just out of curiosity, can we add/set CSS properties to any component? by using an extension maybe?

Yes.

I have worked with dynamic component a lot but never knew faced this problem :sweat_smile:

Sorry to Yusuf Cihan if he is reading this.

1 Like