I can`t create apk

Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/…
________Creating xml in res/drawable/…
________Creating splash png in res/drawable/…
________Creating colors xml
________Creating strings xml
________Creating styles xml
________Creating styles xml v21
________Creating drawables xml v21
________Checking for firebase
________________Firebase components found
________________Firebase config file error

1 Like

you already have your answer

1 Like

Jason file have to be in the asset folder, and the package name have to be ident in firebase and in the json file. Why not look at first what the community wrote about that. This is lazy, if you have a problem, look at first in the community and dont make a post if something is wrong in your app. Sorry for that but it is true , you didnt write a complete sentences, you put only the log into the post and thats it.
Please for the future, look at first into the community, maybe other people had the sam issue like you. so you dont need to write and wait for a answer. You are faster and the forum is not spammed.


I’m getting the same error with the same log even after done all the things the posts in the community said.
Firebase project name = .json file name (in the assets folder) = .apk file name
Still not compiling, any sugestions? Am I doing something wrong so far?

Can you send me your AIA so I can take a look to it?


Did that already, but thank you. Ah… I love your job with the extensions, you own the NMD site right? It helped me long before I started to work in Kodular that have many of them (the ones that I use at least) natively.


Yeap, here it is. Box34.aia (288.1 KB)

I cannot find the google-services.json file inside your AIA
Are you sure you have uploaded it?

Yes, I renamed the file to the name of my project, I tought I was suposed to do that.

Oh, no :sweat_smile:

You have to upload the file as google-services.json, and Package Name must match the inputted on Firebase (which in this case it is com.company.box34 as I can see on the config file)

After doing so, it works properly:

1 Like

Sorry for this newbie question, but… wich Package should be named as com.company.box34? Got myself lost in this last step.

1 Like

It seems like, when you signed up the project on Firebase, you set as package name for your app com.company.box34
So, on Screen1 properties, you will find a property called “Package Name”, where you should input that

1 Like

Ohhh right, got it. Did that, and worked fine. Thank you very much for your attention and patience.

Ps.: By privacy concern, should I rebuild the project in Firebase or remove the .aia file in my post?

1 Like

Yeah, I would recommend rebuild the project in Firebase, as the package name should contain a domain which is owned by you or which hasn’t be registered

Uh Oh… I’m having another issue here.
I test my apps in emulator and it is working fine when I install it with the .apk but when I try to install it on a Android phone it just says that the Installer has stopped and close.
Any clue of what is happening?
Ps.: I often use this phone to test apps and it still working with other projects but I tryed to install into another phone and I got the same error.

Turns out that the images uploaded to the assets folder where too big and heavy, reduced the resolution of them and it solves the problem.

Jason file have to be in the asset folder, and the package name have to be ident in firebase and in the json file.

Good Example:


Bad example:



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.