Image Editor Error

I am getting the following error via companion in my main project. I do not get this error in a smaller test project. (@Mika can you give me your thoughts please)

Attempt to invoke virtual method ‘’ on a null object reference

Here are the blocks. I have tried to two different image editor components (i.e. redragged one), I tried the component as stand alone in a small app to get familiar with it, and I have tried to isolate any variable issues etc.

Means the image path is NULL.
You should check If the variable which you use is not empty

Its not, it is coming straight from the camera component

I tried a few variations. Will try again.

The path is fine, It is from the camera component. It works as a stand alone app, but not as part of my larger app.

However I have discovered the reoccurence of an old bug I had in thunkable, and now it is here. In my app, after the camera component is invoked, and a picture is taken, the image will not render in the image component.

I have to download the image from Cloudinary (which is fine, because I do some processing on it), however Neither of my camera components will show the images, even though the path is correct. I have to pick up the kids, and will try to do some ADB stuff later.

1 Like