Incoming SDK 30 hotfix

Its showing Minimum Api Level not Maximum Target Api Level.
Please read the description carefully.

You can check your apps target api level by using any apk info tools app.
Like this
After exporting your app from kodular.

1 Like

From there you set minimun SDK not targeting SDK.

1 Like

minSdkVersion = 19 (Android 4.4 - 4.4.4 / KitCat)
compileSdkVersion = 30
targetSdkVersion = 30

4 Likes

I can’t see any update in google play for Companion 1.5.2 since for 2 days since the release.

You can download directly, check pinned posts

Yeah, I even published it successfully. Moreover, my app is working flawlessly.

Maybe you don’t use components that makes bugs because Kodular itself said there are bugs.

This is boring and desperate. There are many bugs and their causes are difficult to find. Apps that worked very well, now have many fails. Better to wait for to Kodular release a more stable version similar to the last update. I hope that it will be as soon as possible.

Push notification component not working

2 Likes

New major update coming soon which targets API 30 (Android 11). And in later updates, we will target API 32.

6 Likes

I’m not sure if I understand that correctly. Kodular is already using targetSdkVersion = 30 (ie targeting Android 11).

Don’t you mean targetSdkVersion = 31 (Android 12) or Android 12L (SDK/API = 32)?

Yes, but that Target SDK does not really support Android 10 (file system issues). We are finally fully implementing Target SDK 30 with its full support for the new file system in Android apps.

4 Likes

It’s 31, but effectively 32 :sweat_smile::grin:

Ok I understand. This means that then the File component in particular will be adapted to the new file system (Scoped / Shared storage). And also all other components that can store something. Is that correct?

If so, then I really hope that the same bugs will not be present as with AI2, which I have reported countless times over the past few months.

1 Like

Obviously not. In addition, the bugs with the File component were not fixed. Among other things, it is not possible to copy or move files.

This hotfix is no longer in effect since Fenix 1.5.5. Full SDK 30 support has been added.
SDK 31 will arrive in a few weeks, to comply with Google Play Store deadlines.

1 Like

Have I misunderstood something here? → An update from Kodular Staff

At a glance, this update will bring Target SDK 32 , and will (finally) integrate the new Android file system, so all related bugs to that problem should be solved. It will also include new features and minor improvements as well.
But it will also finally deprecate Google Admob components, as they will no longer be available, even for existing apps. Thus, migration to Google Ad Manager shall be mandatory by that date if you want your app to target Android 12.

:dart: We are aiming to launch this update on the 26th of June 2022. We will keep the community up-to-date if this changes at any point.

1 Like

I tried to test the new file system. First of all with the File component. As soon as I drag it into the Designer, I get an error message (Firefox & Chrome):

Firefox:
grafik

Chrome:
grafik

4 Likes

It is also not possible to click on it (same error) and there are no Properties / permissions displayed at all. The same after reloading / refreshing (browser) multiple times.

1 Like