Is it bug on firebase

Hi, I just try using firebasedb on my app, and I’ve got some error like in the screenshot above.

Please someone point me where i can find the related doc about this error ?

by the way, my app run ok on other app inventor…

thank you


Can you show the blocks?

29 AM

I just checked your project and saw that you had set two different Project Bucket IDs in both Designer and blocks editor. You have to keep only one, either using Designer properties or blocks.

No. On designer sets a chosen value & on initialize, he changes that. Plus by the error, I don’t see Project Bucket to be relatable. NullPointerExeception is not related to this.

to make it simpler, I make 1 screen and nothing on it (designer and blocks) and just 1 FirebaseDB , still I got an error.
and I try with different Firebase URL, still same error.

Is this happened only to me or anyone has a same error when trying firebase ?

Hi @Indra,

Did you set your own Firebase URL and/or Token?

Yes, I set my own firebase url and token based on firebased dashboard

We have fixed the issue.
Firebase works now how it should :slight_smile:

Available at the next update for all.