Kodular companion ( live testing ) doesn't work

what error? how can we know just by saying “it shows error”?

When I Scan or enter the code nothing happens, no error codes,
After taking some time it show as follows,

In the companion screen, nothing happens.

That’s the error…

Working for me. Do you use large assets in your app?

No I opened a blank app and didn’t work…

Are your pc and phone on the same network?

If the Kodular companion developers need it, I can download the app and start a logcat so that you know what exactly happens if this is an app problem that can be recorded into the log file.
Just ask
Btw I will say when I find this problem.
The app doesn’t connect when
-I try to do it online with the PC connected to my phone’s hotspot and my phone to mobile data
-When both devices are on the same network created with a 3rd phone hotspot.
Can’t try with a normal wifi network for now…

same problem here first companion app crashes too often and to connect it to my pc I have to refresh my pc and restart companion app several times then it works it’s actually very annoying sometimes hope Kodular team will fix this bug soon

Troubleshoot your network, that’s all I can say.


Because it works for 99% of users, it has to be something at your end that doesn’t work.

This can be helpful

And some more reading in the same thread.

Of all these threads, I never asked what kind of router you all have. If it’s an old one or new, which model, etc. Search results for 'companion @Boban' - Kodular Community



Not working for me help me after scamming code just nothing happens help me

Not enough information


When i scan code nothing happen in app and in computer
I waited 5-10 minutes

I have used companion just 30 seconds before and it was working.
Check your internet connection.

I always tried but it never worked i have some questions
1.i use usb tethering to pc for internet from mobile
Is this the problem
Or any other

Can you give a demonstration how you use and which type on net?

1 Like

You should be connected to same network then companion will work else it will not work.

I am using JioFi with 149 ( 1.5 GB/day ) plan.Its speed is:

I’m trying from long time to test in phone, it isn’t working.
I have not pc.
It says:

  1. Establishing secure connection.
  2. Stops after 20 or 40 %

I think usb tethering from phone =both have same network

1 Like


Uninstall Kodular Companion


ReInstall it…