Kodular Companion

Try to reinstall, clear data, enable permissions. I don’t know why its crashing though

I have tried it but still geting error

it should be fixed through kodular developers

1 Like

You’re not supposed to click on anything after scanning the code.


1 Like

Aren’t we Supposed to press the Send Button :neutral_face::neutral_face::neutral_face::neutral_face::neutral_face:

Only if you type the code manually.


Okay I feel really Dumb Now. I used to press it before the update and it got away easily:expressionless::neutral_face:

You who have issues with the connection can perform two tests but don’t forget to give feedback what you get for output.

Another scenario may be as I have experienced this myself.

I am connected to my WIFI as I can surf, download and do all other things, the phone reconnects to the network after I’ve been out or similar but in fact, my phone doesn’t communicate with other devices in the network.

Easy step to find out if it so, open command prompt and type ping + your phone’s ip
ex. ping

  1. Disconnect the phone from the network and reconnect again, this has worked for me every time .
  2. Reboot your router.


  1. Start the companion on your device.
  2. Leave the code box blank and click the “Connect button”
  3. In your browser, type http://IPADDRESS:8001/ into the browser with IPADDRESS replaced with the IP address shown on your companion.

If the network will route requests between the two devices, you should get a directory listing. If the connection times out, then your network is still not configured correctly to allow peer to peer communication.



hello Mr @Boban

i followed your method and This is what i get from Test 1-

and this from Test 2 instead of getting directory listing i got a browser page -

so now can you tell me, is there anything wrong with my connection setup

1 Like

Check your router so that port 8001 & 8004 is not blocked, other things like antivirus, add-ons to your browser can cause issues.

Try deleting the Makeroid folder on your phone & maybe even the Appinvetor folder if you have one.


1 Like

Some more reading How Does my Android Device Connect Over Wifi? | Explore MIT App Inventor

  1. Try to reach http://rendezvous.appinventor.mit.edu from >your PC

  2. Try to reach http://rendezvous.appinventor.mit.edu from >your Android device


8001 is working but 8004 is not,

i also reboot the router and before reboot companion was working after 2nd or 3rd try, but after reboot its not working at all.

finally got some visible error…
i tried to test a new project and i got this error

but i already enabled all the permission for the app.

The error message says that you have not enabled the needed permission before to connect the companion…

1 Like

yes… i know what it says that’s why i also provided the permission screen of the companion. all the required permission is enabled.

1 Like

This error can also happen if you have a space in the file name. I suggest that you remove any spaces from the file name then re-upload the asset.

I got the similar error as you got in your image here, but with my image of course.


This happened when I imported a extension and upgraded the same extension, after that I got this error.
Buy reloading the creator.kodular and restarting the companion solved the issue.


1 Like

yes… thanks for the help and i also found out that removing space from assets file names will solve this issue as well. but still the companion takes a lot of time to load, slower than previous version

1 Like

BTW, wondering why people click on these links :thinking::thinking:


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.