Kodular is not Strong Enough ? Someone Cut Power


(Nepali Channel) #1

I have check all process to fix this error but cant fix it !
and now i think my aia file is big so kodular cannot compile it orr kodular is not strong enough

i got this error !

Kodular is unable to compile this project.
The compiler error output was
________Preparing application icon
________Creating animation xml
________Creating fragment xml
________Creating listview xml in res/layout/…
________Creating listview xml in res/layout-v21/…
________Creating xml in res/drawable/…
________Creating splash png in res/drawable/…
________Creating colors xml
________Creating strings xml
________Creating styles xml
________Creating styles xml v21
________Creating drawables xml v21
________Checking for firebase
________Creating provider_path xml
________Generating manifest file
________Attaching native libraries
________Attaching Android Archive (AAR) libraries
________Attaching component assets
________Invoking AAPT
AAPT time: 0.558 seconds
________Compiling source files
(compiling io/kodular/sushil_balami200/affirmationpodcast/Screen1.yail to io.kodular.sushil_balami200.affirmationpodcast.Screen1)
(compiling io/kodular/sushil_balami200/affirmationpodcast/main.yail to io.kodular.sushil_balami200.affirmationpodcast.main)
(compiling /tmp/runtime1724805839134984275.scm to com.google.youngandroid.runtime)
Kawa compile time: 1.713 seconds
________Invoking DX
DX time: 4.75 seconds
________Invoking ApkBuilder
com.android.sdklib.build.ApkCreationException: Failed to add /tmp/1552128808523_0.2332332997778871-0/youngandroidproject/…/build/tmp/classes3.dex
YAIL compiler - ApkBuilder failed.
.

**I tried all way to fix it there are not any error signs on the blocks please help me **


(Kleyber Derick) #2

Some questions:

1 - How big your AIA is?
2 - How are you so sure Kodular is not strong enough?
3 - Why are you tagging kodular team in your post? Have you read this? How to ask a question? and this: FAQ - Kodular Community


(Nepali Channel) #3

Yes read many times…
My AIA is 1.6 MB .


(Deepanshu Arya) #4

First check your blocks and logic and then clear your browser cookies and cache , try another browser or incognito/private mode
If it Donot work msg me surely
Also include extension used in the project


(Deepanshu Arya) #5

I think this might have solved your problem so change your title and don’t comment on kodular’s power and change topic to discuss


(mannveer janu) #6

bro check the errors on ur blocks section u have loader more please check


(Aravind Chowdary) #7

Post your block image if you can so we can help you fix it !!

May be you have set something wrong.


(Nepali Channel) #8

Not works…
Already done before u say
I will not send u AIA…
It’s personal and have paid extension…
U r not any moderator and prokoder too…
So I will not send u


(David Ningthoujam) #9

just post the screenshots of blocks and name of the extension u used :smiley:


(Deepanshu Arya) #10

Do you face this problem only in this project or other also and I also said you to list extension used


(Nepali Channel) #11

Other tooo :sweat_smile::sweat_smile::sweat_smile:


(Aravind Chowdary) #12

I think I didn’t ask you for AIA. I just asked yo post a block image.


(Deepanshu Arya) #13

Try different browser, firefox recommend


(tomer) #14

Your blocks may be too long


(Andro King) #15

Neither your block Is More neither your aia size is big neither your browser has any problem.the problem is that you are using two extension having same library @mobiletech150 @kimyunz01 long time no see kimyunz​:joy:


(Nepali Channel) #16

Idc u r just a pity ones…
@Androking