Kodular Starter Connection Test says "Phone not connected." It IS connected

Hi, I’m new to Kodular and I apologize if this is the wrong Category, but I saw no categories for tech support questions.

I’ve been using MIT App Inventor successfully with my USB connected phone. However, I just cannot get the TEST to use my phone successfully.

I finally added the Kodular Companion thru the Play Store, but it takes forever to download each time I want to test my app. I’d rather use the USB test. Here’s what I get:

  1. adb has connected my phone, the terminal window says it is connected.
  2. python MakeroidStarter.py is running and “bottle” is installed (ran pip install -r requirements.txt)
  3. Starter terminal window displays:

(‘Makeroid Starter’, ‘v1’, ‘for’, ‘Linux’)

Bottle v0.12.13 server starting up (using WSGIRefServer())…
Listening on
Hit Ctrl-C to quit.

Checking device…
(‘Problem checking for devices : status’, 1, ‘\n’)
Test Failed! - - [09/Jun/2019 10:59:28] “GET /utest/ HTTP/1.1” 200 32

Samsung Galaxy S6 has Developer options ON and Developer Option USB debugging checked.
Dialog popped up asking for permissions, checked on

./adb devices (06-09 10:59:12)
List of devices attached
02157df29da60415 device

Everything looks copacetic, but the Test USB still gives me this:

The Kodular Starter helper does not appear to be running.

So I go to the Need Help link, and press the buttons and it says:

Yes, it is running.
No, it is not connected.

I’ve tried multiple phones, I’ve rebooted and restarted everything. Any help would be greatly appreciated.

Please try again by terminating the script and executing it. This will kill the current ADB daemon session and restart a new one because it seems that script can’t access the adb command. Do you have the adb command set in the path environment variable?

If the above didn’t work, replace your script with latest version of your OS from here: GitHub - Kodular/Starter: Kodular Starter to test apps live via USB

1 Like

Installed Starter-master, it runs and finds adb. Also ran pip install -r requirements.txt .

: python linux.py (06-09 18:37:11)
(‘Kodular Starter’, ‘Version 1.3 Draco, for Linux’)

Bottle v0.12.15 server starting up (using WSGIRefServer())…
Listening on
Hit Ctrl-C to quit.

Ping… - - [09/Jun/2019 18:37:48] “GET /ping/ HTTP/1.1” 200 40
Checking device…

  • daemon not running; starting now at tcp:5037
  • daemon started successfully
    Test Successful! - - [09/Jun/2019 18:37:53] “GET /utest/ HTTP/1.1” 200 70
    Checking device…
    Test Successful! - - [09/Jun/2019 18:37:53] “GET /utest/ HTTP/1.1” 200 70

Check page says Starter is running and phone is connected.

But still NO joy. Will not connect via USB. USB Developer options are good to go on the phone.

Why would it give me an error if all looks nominal?


Reading the logs you posted, I didn’t find anything wrong with it. I should have been worked. I will check and get back to you soon.