List is no longer a list after saving and retrieving via Firebase

Hi there. If I upload a list (text) via Firebase and this list is then downloaded, then it says this is no longer a list … The variable is also on “create empty list”. But even that does not lead to a solution …

Am I missing something? Thanks in advance.

Well, I’ve managed that with “csv row text”. Now it’s a list again. However, I have another problem now. When I check if an item is in the list, I always get “false”, even if the item is in the list …

could you please show us your blocks so we can take a better look at it?


Here is the problem. Even if the item is in the list, it will display false.

1 Like

Try printing the output on a label so you can take a look at how actually is the text/list formatted, there might " " added.

The format is: ((item))
And when I check if it’s a list, it says “true”, which is why the query should normally work, but it doesn’t.

1 Like

Try selecting an item like at index 3or4 or use length of list and tell me whats the result

So, I only have one item currently in there to test it. It also shows me that there is 1 item.

When I select an item with the index 1 comes: (item)

1 Like

Can you add more items?
If you are getting the result: (item) then possibly its a list within a list

So I have now added more, but it says that there is still 1 item in it, but there are 3 now.
If you select index 1, the whole list appears.

The list is perfectly fine, it is only 1 list if you save in Firebase. The problems only come when you download the list. Seems like you said it’s a list within a list, just how do I change that now?

This will solve your problem but i feel the problem lies when you are uploading the list

Unfortunately, this does not solve the problem because the entire list is output at index 1.

Did you try it?

Yes, i tried it.
I tried this too, and strangely enough, that’s how it would work …

1 Like

When you are checking is in list?
in the list field instead of tmplist put select item (list:tmplist,index:1)

This will give you the list you want
You are getting a list within a list thats of length 1 always.
the first item of the templist is the list you want so selecting index 1 of list templist should give you the actual list.

1 Like

I understand what you mean, but then I get a “runtime error”. As I said, with “contains text piece” it works strangely …

1 Like

whats the error?

The error is “The operation is in list? cannot accept the arguments: , [item], [(item1 item2 item3)]”

It maybe possible the list thats in the list is actually not a list so thats what causing the error.

So you would have to cut the() using segment block and then split at spaces this will work fine until you have items that have an internal space